Results 1 to 9 of 9

Thread: speakers test in Yast but no sound in Amarok

  1. #1
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default speakers test in Yast but no sound in Amarok

    I am running Suse 11.2 on a MacPro. I have configured my SoundSticks to be the preferred device in Yast:Sound. I have left the 631xESB/632xESB High Definition Audio Controller and a Logitech USB Headset "Not configured" so that the SoundSticks are at index 0 and are the only configured sound device.

    I can hear the SoundSticks when I try the Other : Play Sound Test option in that control panel, and I hear it in Personal Settings : Sound and Video Configuration, when I click the Test button. So I know the speakers are working.

    When I am in Amarok, streaming music from, let's say, SomaFM, I don't hear anything. I used this command in bash to see what application had hold of my sound device:
    lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    amarok 9042 brian 13u CHR 116,4 0t0 45138 /dev/snd/controlC0
    So that looks okay. But does anyone know what the missing piece is? What else has must be done for me to hear music on those speakers? Thanks for your help.

  2. #2
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: speakers test in Yast but no sound in Amarok

    Hi,

    Did you get an error message, or just no sound?

    Have you tried running amarok from the terminal so that you can see any warnings/errors in the terminal window?


    Regards,
    Barry.
    Desktop: openSUSE 11.3 (x86) LXDE
    Laptop: Arch Linux (x86_64) GNOME 3

  3. #3
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default Re: speakers test in Yast but no sound in Amarok

    Hi, Barry.

    Without using the --debug flag, this is what I get:
    InnoDB: The log sequence number in ibdata files does not match
    InnoDB: the log sequence number in the ib_logfiles!
    091204 18:23:55 InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    Object::connect: No such signal KLineEdit::downPressed()
    I previously shut down Amarok using Quit in the system tray, so not sure why "Database was not shut down normally".

  4. #4

    Default Re: speakers test in Yast but no sound in Amarok

    The reason why you hear sound while testing in YaST and no sound in amarok could be that YaST writes directly to the audio device while amarok uses a sound server (pulseaudio or phonon) which might be misconfigured or refusing connections.

  5. #5
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default Re: speakers test in Yast but no sound in Amarok

    This is a great example of linux's spaghetti-method of system configuration (I'm originally of the Mac OS persuasion).

    I unplugged external sound devices other than the Harmon Kardon Sound Sticks.

    When I type "cat /proc/asound/cards" in the console I see:
    1 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xf0e00000 irq 23
    2 [SoundSticks ]: USB-Audio - SoundSticks
    harman/kardon SoundSticks at usb-0000:00:1d.7-5.3, full speed
    In Amarok's "Sound System Configuration" -- "Sound and Video Configuration" window, if I hover the mouse over the line that says "harmon/kardon SoundSticks (USB Audio)", I see:
    ALSA : x-phonon: CARD-2, DEV=0
    ALSA : plughw: CARD-2, DEV=0
    OSS: /dev/dsp2
    OSS: /dev/audio2
    I'm not sure what to do with that information.

    I found something at the Amarok wiki under one of the questions there: How can I change where the audio is output to?
    Enter the word "plughw:" and the name of your card in the box labeled "device used for stereo output:" in the xine-engine configuration tab. For example: "plughw:Headset"
    Alternatively, ... use this entry to make ... USB headphones work. "hw:Headset,0"
    I can't find the "xine-engine configuration tab?".
    Instead, for now, I'm going to try method 2 under that question: "Using a specific soundcard".

    I'll write again after I've tried it.

  6. #6
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default Re: speakers test in Yast but no sound in Amarok

    I installed xine in YaST but could not find a "xine-engine setup screen". It informed me that due to legal issues with the version installed, I did not have access to some configuration screens.

    On another front, I put an audio CD in the computer and am able to play it (and hear it) using Kaffeine.

    I wanted to see if Amarok could play an audio CD. I open the CD media in Amarok and see folders for CDA, FLAC, Full CD, Ogg Vorbis, each of which contain files, and the root of the CD also contains wav files. I can't add any of these to my playlist. So in my attempt to get sound in Amarok, I can't even get the media to play. Is this another topic? Hope someone can help. Thanks.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,489
    Blog Entries
    37

    Default Re: speakers test in Yast but no sound in Amarok

    Quote Originally Posted by fogelfish View Post
    I installed xine in YaST but could not find a "xine-engine setup screen". It informed me that due to legal issues with the version installed, I did not have access to some configuration screens.

    On another front, I put an audio CD in the computer and am able to play it (and hear it) using Kaffeine.

    I wanted to see if Amarok could play an audio CD. I open the CD media in Amarok and see folders for CDA, FLAC, Full CD, Ogg Vorbis, each of which contain files, and the root of the CD also contains wav files. I can't add any of these to my playlist. So in my attempt to get sound in Amarok, I can't even get the media to play. Is this another topic? Hope someone can help. Thanks.
    I recommend you install some software and proprietary codecs to help solve this problem. And to ensure you have no problem installing software, I recommend you set up your software repositories with 4 and ONLY 4 software repositories. Those repositories are OSS, Non-OSS, Update and Packman. Just those 4. No others None. Only OSS, Non-OSS, Update adn Packman. For openSUSE-11.2 there is guidance here for setting up those 4: Repositories/11.2 - openSUSE-Community You will likely discover OSS, Non-OSS, and Update already set up and you only need to add Packman. Please only those 4. In particular do NOT add videolan as that is known to cause problems as it puts codecs in places where Packman packaged applications can not find them.

    Once those 4 are setup, go to YaST > Software > Software Management and install the packman packaged libxine1 , libxine-codecs, and xine-ui. You can tell packman packaged versions by the "pm" in the file version. Replace any Novell / SuSE-GmbH packaged versions.

    Please also read our stickie:
    NEW Users - openSuse Pre-install (general) PLEASE READ - openSUSE Forums
    and
    NEW Users - Suse-11.2 Pre-installation PLEASE READ - openSUSE Forums

  8. #8
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default Re: speakers test in Yast but no sound in Amarok

    oldcpu,

    The packman versions of libxine,etc., did the trick. Fantastic!
    Thank you for the solution.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,489
    Blog Entries
    37

    Default Re: speakers test in Yast but no sound in Amarok

    Quote Originally Posted by fogelfish View Post
    The packman versions of libxine,etc., did the trick. Fantastic!
    Thank you for the solution.
    Congratulations.

    I forgot to mention select the xine sound engine in Amarok, but I see you figured that out. Well done in sorting this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •