Results 1 to 2 of 2

Thread: I broke KGpg on SuSE 11.2

  1. #1

    Unhappy I broke KGpg on SuSE 11.2

    Installing SuSE 11.2. Ran KGpg the first time, all went well. But I wanted to use my existing keys, not new ones, so I nuked the newly created pubring.gpg, secring.gpg, trustdb.gpg and symlinked the older ones into /home/andy/.gnupg.

    Now when I run KGpg as user andy the icon bounces up and down, but nothing happens. Doing ps -A|grep gpg shows the process, but nothing exists on the screen.

    I've tried nuking, reinstalling etc, with a reboot after each nuke, no change.

    I ran it as root, it runs correctly. So there is a permissions problem somewhere:
    + /usr/share/applications/kde4/kgpg.desktop is rw-r--r-- root but so are all the other .desktops.

    + The desktop calls the appplication with kgpg %U, which implies there is a .conf or rc file somewhere setting the users.

    + I located /usr/share/kde4/apps/kgpg/kgpg.rc, but it doesn't mention users or permissions.

    + I located /usr/bin/kgpgconf] but it is a binary.

    + I located /usr/share/kde4/config.kcfg/kgpg.kcfg, no mention of users.

    But I removed all three, upgraded kGpg and tried again. No change.

    I then commented out cross-correlation in /home/andy/.gnupg/gpg.conf and tried again. No change.

    I've tried all of the following without success:
    + Nuke \home\andy .gnupg and try again
    + Nuke \home\andy .gnupg, copy the /root/.gnupg over, reset owner and permissions to andy:users 0755 and try again

    I guess I can run it as root, but I'd really rather fix this. Of course I know that I'll figure it out as soon as I postthis but... :-(

    Thanks in advance,
    Andy Lavarre
    alavarre(with the email address)

  2. #2

    Default Re: I broke KGpg on SuSE 11.2

    Well, like I said:

    Finally I uninstall, reboot, and manually delete what is left over including:

    all of which I had missed before. Then reinstalled kGpg and ...
    It works!

    So now I try symlinking the keys again, and again it breaks. This time, nuke /home/andy/.gnupg/ and /home/andy/.kde4/share/config/kgpgrc (the other two files no longer exist and there is no other kgpg session file) and restart kGpg. TBTG this works.

    This time I specify /data/comms/crypto/.../ in response to the setup question of "Where is your conf file?" and then import the pubring and secring from the same location.

    OK, so now I can nuke .gnupg, right?

    Wrong. Same problem all over again.

    This time, nuke /home/andy/.gnupg/ and /home/andy/.kde4/share/config/kgpgrc. Then nuke the keys in .gnupg but do not delete the folder.

    Now restart kGpg. And this works. But the keyrings are still stuck in /home/andy/.gnupg/

    Well, enough for today. But I would really like to have the keyrings reside in the /data/... partition, not the /home partition.

    Cheers, Andy Lavarre

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts