Results 1 to 7 of 7

Thread: Alt-tab not working

  1. #1
    Join Date
    Aug 2009
    Location
    Mexico City
    Posts
    22

    Default Alt-tab not working

    Hi there again, community. If someone can identify what is stealing alt-tab. I can open the menus using alt, but when i use alt-tab it will not work for switch apps. If a textbox has focus, alt-tab only writes a tab (since i wanted to change apps from aMSN). Using opensuse 11.2 with compiz fusion.

    Thanks again from the help!
    Box: Acer Aspire One ZG5, OpenSuse 11.3

  2. #2
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: Alt-tab not working

    Hi,

    Did it work before and stop working?

    Are you using GNOME?

    Did you check the desktop effects menu?


    Regards,
    Barry.
    Desktop: openSUSE 11.3 (x86) LXDE
    Laptop: Arch Linux (x86_64) GNOME 3

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Alt-tab not working

    We'll need to know which Desktop Environment you're using KDE or GNOME and then we'll need to make sure you have the right packages installed so please open a terminal and provide the output of:

    Code:
    rpm -qa --last "*compiz*"
    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    Join Date
    Aug 2009
    Location
    Mexico City
    Posts
    22

    Default Re: Alt-tab not working

    I'm using KDE. And here's the output:

    > rpm -qa --last "*compiz*"
    compiz-emerald-0.8.4-1.1 mar 01 dic 2009 17:26:41 CST
    compiz-emerald-themes-0.6.0-2.1 mar 01 dic 2009 17:26:36 CST
    compizconfig-settings-manager-0.8.4-10.1 mar 01 dic 2009 17:25:49 CST
    python-compizconfig-0.8.4-4.1 mar 01 dic 2009 17:25:41 CST
    compiz-plugins-extra-0.8.4-100.1 mar 01 dic 2009 17:25:37 CST
    libcompizconfig-0.8.4-10.1 mar 01 dic 2009 17:25:06 CST
    compiz-plugins-main-0.8.4-101.1 mar 01 dic 2009 17:25:02 CST
    compiz-manager-0.0.1_git080201-62.1 mar 01 dic 2009 17:24:49 CST
    compiz-0.8.4-167.1 mar 01 dic 2009 17:24:46 CST
    compiz-kde4-0.8.4-167.1 mar 01 dic 2009 17:24:33 CST
    compiz-branding-openSUSE-0.8.4-167.1 mar 01 dic 2009 16:15:49 CST
    compiz-gnome-0.8.4-167.1 mar 01 dic 2009 16:15:36 CST
    >
    Box: Acer Aspire One ZG5, OpenSuse 11.3

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Alt-tab not working

    Do you use both KDE and GNOME? You have both of the compiz packages for both KDE and GNOME. Which isn't a good thing. If you're just using KDE then get rid of the package compiz-gnome.

    Also make sure in the CCSM that one of the application switching plugins is active, either the Shift Switcher or Application Switcher plugin (one or the other, not both).

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  6. #6
    Join Date
    Aug 2009
    Location
    Mexico City
    Posts
    22

    Default Re: Alt-tab not working

    Great Ian! Thanks!

    I had two app switchers as you described, and neither was mapped to keys. Strange, since i haven't modified the compiz config at all.

    Thanks again, man!
    Box: Acer Aspire One ZG5, OpenSuse 11.3

  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Alt-tab not working

    Glad I could help

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •