Results 1 to 9 of 9

Thread: VirtualBox not starting

  1. #1
    uwekoch NNTP User

    Default VirtualBox not starting

    Hello,
    after upgrading from openSUSE 11.1 to 11.2 by new installation my virtualbox is not running anymore.
    I tried the OSE version from the openSUSE DVD as well as the SUN version from SUN's download site.
    The VirtualBox software is starting but when I want to start a VM this is not possible with this message :

    Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    '/etc/init.d/vboxdrv setup'

    as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.


    The reinstallation of kernel module ends like this :

    pc-uwe-1:~ # /etc/init.d/vboxdrv setup
    Recompiling VirtualBox kernel module, NOT. It has been packaged.Recompiling VirtualBox netflt kernel module, NOT. It has been packaged. done
    Starting VirtualBox kernel module failed
    (modprobe vboxdrv failed. Please use 'dmesg' to find out why)
    pc-uwe-1:~ #


    and dmesg shows this :

    [ 250.830204] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)


    This was tested with the OSE version.

    After deinstalling the OSE version and installing the current SUN version 3.1.0 this messages appear during module reinstallation :

    pc-uwe-1:~ # /etc/init.d/vboxdrv setup
    Stopping VirtualBox kernel module done
    Recompiling VirtualBox kernel module failed
    (Look at /var/log/vbox-install.log to find out what went wrong)
    pc-uwe-1:~ # cat /var/log/vbox-install.log
    Makefile:155: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
    make KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/tmp/vbox.12 SRCROOT=/tmp/vbox.12 modules
    test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
    echo; \
    echo " ERROR: Kernel configuration is invalid."; \
    echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
    echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
    echo; \
    /bin/false)

    ERROR: Kernel configuration is invalid.
    include/linux/autoconf.h or include/config/auto.conf are missing.
    Run 'make oldconfig && make prepare' on kernel src to fix it.

    mkdir -p /tmp/vbox.12/.tmp_versions ; rm -f /tmp/vbox.12/.tmp_versions/*

    WARNING: Symbol version dump /usr/src/linux-2.6.31.5-0.1/Module.symvers
    is missing; modules will have no dependencies and modversions.

    make -f scripts/Makefile.build obj=/tmp/vbox.12
    /tmp/vbox.12/Makefile:155: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
    gcc -Wp,-MD,/tmp/vbox.12/linux/.SUPDrv-linux.o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.4/include -Iinclude -I/usr/src/linux-2.6.31.5-0.1/arch/x86/include -include include/linux/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fomit-frame-pointer -I/usr/src/linux/include -I/tmp/vbox.12/ -I/tmp/vbox.12/include -I/tmp/vbox.12/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.12/linux/SUPDrv-linux.o /tmp/vbox.12/linux/SUPDrv-linux.c
    /tmp/vbox.12/linux/SUPDrv-linux.c:1: error: code model 'kernel' not supported in the 32 bit mode
    /tmp/vbox.12/linux/SUPDrv-linux.c:1: sorry, unimplemented: 64-bit mode not compiled in
    make[2]: *** [/tmp/vbox.12/linux/SUPDrv-linux.o] Error 1
    make[1]: *** [_module_/tmp/vbox.12] Error 2
    make: *** [vboxdrv] Error 2
    pc-uwe-1:~ #


    What is to be done to get VirtualBox running again ?
    I need the SUN version because of USB support.

    Regards
    U w e

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: VirtualBox not starting

    Other guys have asked the same question in the forum. Please do a search.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3
    Join Date
    Apr 2009
    Location
    Stuttgart, Germany
    Posts
    113

    Default Re: VirtualBox not starting

    I had the same issue, then installed the package "kernel-syms". After this, the "/etc/init.d/vboxdrv setup" worked fine.

  4. #4

    Default Re: VirtualBox not starting

    Quote Originally Posted by PVince81 View Post
    I had the same issue, then installed the package "kernel-syms". After this, the "/etc/init.d/vboxdrv setup" worked fine.
    It's works for me too.

    I'm using openSUSE 11.2 "Emerald" and kernel:

    suse:/home/alessandro/# uname -a
    Linux suse 2.6.31.8-0.1-desktop #1 SMP PREEMPT 2009-12-15 23:55:40 +0100 i686 i686 i386 GNU/Linux

  5. #5
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: VirtualBox not starting

    Same here, no issues running VBox on 11.2.

    As posted before, there is a thread on this forum with the specific packages to install and the instructions.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: VirtualBox not starting

    If you have a new kernel you need new sources.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VirtualBox not starting

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    upscope NNTP User

    Default Re: VirtualBox not starting

    gogalthorp wrote:

    >
    > If you have a new kernel you need new sources.
    >
    >

    Also need to rerun "/etc/init.d/vboxdrv setup" after install of Vbox.
    If not done vbox will not start.
    --
    Russ
    [openSUSE 11.2 (2.6.31.8-0.1-desktop, x86_64] KDE 4.3.4 release 2,
    Intel Core 2 Dual E7200, 4 GB RAM, GeForce 8400 GS, 320GB Disc (2)

  9. #9
    Join Date
    Nov 2009
    Location
    Germany
    Posts
    64

    Default Re: VirtualBox not starting

    Box 1: Striker Extreme/NVIDIA GT 8600 SLI/E 8500/8 GB RAM/12.2 64 bit
    Box 2: ASUS P5KPL/NVIDIA GT 9500 / Pentium D/ 2 GB RAM /12.2 64 bit
    Laptop: Toshiba Sat. A 100/ 4 GB Ram / 12.1 32 bit
    Laptop: Toshiba Sat. A 660 / 4 GB Ram / 12.1 64 bit

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •