Results 1 to 6 of 6

Thread: Yakuake won't activate via hotkey

  1. #1

    Default Yakuake won't activate via hotkey

    I have a curious problem. I'm running openSUSE 11.2 w/ KDE4, and yakuake won't activate via hotkey. I've tried different hot keys, but to no avail. I prefer F12.

    If yakuake is running but is rolled up and out of view, F12 (or whatever hot key I set) does nothing. If I call the app from krunner or from a command line, it rolls down, and it stays there until I tell it to do otherwise. If I press F12 at that point, it correctly rolls up and out of the way, but then won't re-appear with F12.

    So... I went into my Input Actions config, and added an action that simply calls yakuake with F12. It then seems to work fine. But that shouldn't be necessary, and my fix seems a bit over the top.

    Any ideas as to why it's doing this? I'm bewildered.

  2. #2

    Default Re: Yakuake won't activate via hotkey

    Okay, I think I have the answer to my own question. Yakuake's config showed that F12 was associated, but viewing the keybindings in the KDE preferences ("Personal Settings -> Global Keyboard Shortcuts -> yakuake") showed it as set to custom with no key assigned.

    When I selected the default (F12) and clicked apply, it warned me that I had an input action with the same key. With one click, I applied the change and disabled the input action. Now it's working.

    Sounds like the yakuake settings dialog might have a bug in it. Anyone else experiencing this issue, or is it just me?

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Yakuake won't activate via hotkey

    What have you here
    Menu editor: Applications - System - Terminal

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Yakuake won't activate via hotkey

    No, it was set to start at login (KDE autostart dialog). I verified it was already running when I tried the hot key. F12 did nothing.

    Even tho the app was running, I'd run/call the app again, and that would get it to roll down. When I selected F12 in the KHotKeys section of KDE's system preferences window, it worked fine. But when I'd selected F12 via Yakuake's shortcuts screen, it didn't.

    In any event, it works now. Maybe my situation was just a fluke.

  5. #5
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: Yakuake won't activate via hotkey

    Yakuake is a strange customer. It autostarts with a default install of 11.1 or 11.2 KDE, and all you need is F12 to open it. Nice. But then at some point, shortly after the install, it no longer responds to F12. Dunno why (I certainly haven't messed with hotkeys) but I can't be bothered to find out.
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  6. #6

    Default Re: Yakuake won't activate via hotkey

    What??? Sarcasm?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •