Results 1 to 5 of 5

Thread: LD_PRELOAD keeping mozilla from starting

  1. #1

    Default LD_PRELOAD keeping mozilla from starting

    I was seeing an odd thing where thunderbird or firefox would fail to startup. Nothing would happen.. the terminal would just there until I canceled out.. I later discovered the apps would start if I did 'su - <myaccount>' and logged in as myself again.. This pointed to some kind of env issue causing the problem.. I compared the environments before and after the 'su - ' command and discovered the culprit to be LD_PRELOAD. Once I unset the value, I was able to start both thunderbird and firefox normally.


    This is what LD_PRELOAD was being set to in the default login session -
    LD_PRELOAD=/usr/NX/lib/libesddsp.so.0 /usr/NX/lib/libesd.so.0

    This variable isnt defined in any of my startup files and I cannot find any reference to it in the standard shell startup files in /etc or the /usr/NX folders. I guess the NoMachine package is setting this value on-the-fly or via a binary file somewhere.

    Can someone enlighten me what this variable is used for and if it is important etc? In my searching around, it appeared to mostly show up in sound related issues.

    Many thanks

  2. #2

    Default Re: LD_PRELOAD keeping mozilla from starting

    Quote Originally Posted by mscroggi View Post
    Can someone enlighten me what this variable is used for and if it is important etc?
    "man ld.so" explains it.

  3. #3

    Default Re: LD_PRELOAD keeping mozilla from starting

    I've been experiencing the same problem for a while now. The only bug report of it I've seen is here:

    Gentoo Bug 282117 - www-client/mozilla-firefox-3.5.2-r1 : /usr/bin/firefox fails for $USER logged in via !M NX client to !M free nxserver due to LD_PRELOAD

    Apologies for the late reply to this thread, but I've only just noticed it while googling for any updates on the bug.

    Disabling multimedia support allowed me to start firefox, but disabled my audio. Since I use Songbird which is Mozilla based I'm caught in a catch 22.

    Please update the thread if you find any fixes, updates or workarounds.

  4. #4

    Default Re: LD_PRELOAD keeping mozilla from starting

    If you're using a terminal to start Firefox then
    Code:
    $ LD_PRELOAD="" firefox
    Will let you run it. I don't have nxclient, but I would think it's attempting to intercept sound library calls, to play stuff locally rather than on the host machine using custom Enlightened sound daemon code (confirmed by reading the Gentoo bug report).

    Alternative work round suggested in the bug report is to turn off the NX multi-media services.

  5. #5

    Default Re: LD_PRELOAD keeping mozilla from starting

    I did notice on the machine where the problem was happening, the 'enable multimedia support' was checked in the nx client. Thanks for the tip!..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •