Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Opensuse 11.2 remote administration

  1. #1
    Join Date
    Nov 2008
    Location
    Budapest, Hungary
    Posts
    23

    Default Opensuse 11.2 remote administration

    Opensuse 11.2 remote administration.
    If configured at vnc and www (5901 and 5801) port we got just a black screen. No firewall to block it.
    Any advise?

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: Opensuse 11.2 remote administration

    Some questions to help us:
    • What version of openSUSE are you using?
    • What Desktop Environment are you using?
    • Are you running vnc in openSUSE as a client or as a server?
    • If you are running openSUSE as a server, what Desktop are you serving out?
    • If you are running openSUSE as a client, what Desktop/operating system are you importing?
    • openSUSE comes with several types and methods for vnc, which one did you use?


    You said: Any advise? -- maybe this will help: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Nov 2008
    Location
    Budapest, Hungary
    Posts
    23

    Default Re: Opensuse 11.2 remote administration

    "What version of openSUSE are you using? "
    "Opensuse 11.2"

    "What Desktop Environment are you using?"
    KDE

    "Are you running vnc in openSUSE as a client or as a server? "
    If then with twm on separated port. But does not make sense other vnc running or not the result are same. Of course the vncserver on other port working fine.

    "If you are running openSUSE as a server, what Desktop are you serving out? "
    KDE

    "openSUSE comes with several types and methods for vnc, which one did you use? "
    The remote adminstration is configured from Yast/NetworkServices/RemoteAdministration. This use Xvnc?

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: Opensuse 11.2 remote administration

    That button in Yast actually opens the firewall on channel 1 (5901). The properties associated with that can be viewed in the Yast --> net services --> xinetd button. I see that the "remote admin" button actually turns on a 1024x768 screen of the same type as your default desktop (KDE for you). The software is TightVNC / xorg-x11-Xvnc

    Sadly, it's not working in openSUSE 11.2.

    This page will give you a working TightVNC server for openSUSE 11.2 by a method that works:
    TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

    And if you look at this thread and check posts by oldcpu you'll see how to use the other fork of vnc (namely x11vnc) in openSUSE 11.2:
    VNC is sometimes working - openSUSE Forums
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Nov 2008
    Location
    Budapest, Hungary
    Posts
    23

    Default Re: Opensuse 11.2 remote administration

    "Sadly, it's not working in openSUSE 11.2."
    My statistic is the flowing:
    OpenSuse 10.3 - working fine
    SLES11 - working fine
    OpenSuse 11.1 - respond "Not a valid vnc server"
    OpenSuse 11.2 - balank screen (on vnc and on www port)
    Of course I can setup any complicated remote acess, but this one click remote management was very comfortable service of Suse...

  6. #6

    Default Re: Opensuse 11.2 remote administration

    Quote Originally Posted by kzsolt2 View Post
    "Sadly, it's not working in openSUSE 11.2."
    My statistic is the flowing:
    Thats the same history i experienced.

    In my 11.1 it was just a shell script parameter in the wrong place, i think some geometry parameter (like the 768 in 1024x768) was treated as a port number which didn't exist.
    I fixed the script and it worked.

    Now about 11.2:

    Im not so experienced, but i "believe" this is the reason for the "black-screen":
    It seems that a Xvnc-Server is successfully started when a user connects to the port (e.g. 5801 or 5901) but no application or desktop is started. There is just nothing to be seen.
    Thats why its black.

    I tried around a bit with self-written scripts similar to svnserver to improve this but no success yet. The point is that the Xvnc (or new script) is to be started by xinetd which makes it a bit more complicated (unless i don't understand some things yet.)

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: Opensuse 11.2 remote administration

    IME works fine if you use the startup command "dbus-launch vncserver" instead of the traditional command "vncserver"
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  8. #8

    Default Re: Opensuse 11.2 remote administration

    Quote Originally Posted by swerdna View Post
    IME works fine if you use the startup command "dbus-launch vncserver" instead of the traditional command "vncserver"
    But neither vncserver, nore sbus-launch work when they are started via /etc/xinetd.d/vnc.

  9. #9
    lsnrw NNTP User

    Default Re: Opensuse 11.2 remote administration

    Hello together,

    maybe I have a solution for the problem.

    In our systemlog was an entry when I tried to established a connection with the vnc-server:

    Dec 29 09:37:52 S-BS-GE-NQE4 kdm: fe80::21a:4bff:feaf:b368:1[10545]: Cannot connect to fe80::21a:4bff:feaf:b368:1, giving up
    Dec 29 09:37:52 S-BS-GE-NQE4 kdm[1442]: Display fe80::21a:4bff:feaf:b368:1 cannot be opened


    VNC tries to establish a connection with the IPv6 address of eth0.

    At first you have to activate IPv6 under the global options of the network manager.

    After this you have to reboot your system!

    In a terminal you can find out the IPv6 address of eth0
    Just enter ifconfig:

    ifconfig
    eth0 Link encap:Ethernet Hardware Adresse 00:1A:4B:AF:B3:68
    inet Adresse:10.101.147.80 Bcast:10.101.147.255 Maske:255.255.254.0
    inet6 Adresse: fe80::21a:4bff:feaf:b368/64

    At last you must add an entry in the /etc/hosts file
    for the IPv6 address

    For example:

    fe80::21a:4bff:feaf:b368 hostname.domain hostname

    IPv6 address, hostname and domain should be the original variables of your system.

    Please let me know if this solution works with your systems as well.

    Good luck!

  10. #10
    lsnrw NNTP User

    Default Re: Opensuse 11.2 remote administration

    There is also a second localhost address necessary, like this:

    127.0.0.2 hostname.domain hostname

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •