Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How to disable automatic updates (10.3)?

  1. #1

    Default How to disable automatic updates (10.3)?

    Hi,

    Given 10.3 has just been discontinued, there won't be any more updates. But I can't find how to disable automatic updates... According to the manual, the applet config should offer an "automatically start updater on login" checkbox, but mine doesn't (Gnome).

    I couldn't find in Yast either.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to disable automatic updates (10.3)?

    Yast Software repositories

    Just Disable it
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: How to disable automatic updates (10.3)?

    What a light-speed answer :-)

    Disable what? I still want to be able to install new software!

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: How to disable automatic updates (10.3)?

    JUst disable the opensuse updater in the tray.
    Right click, configure. Uncheck 'automatically start at launch"
    and then ok out of it. Right click on the icon again and select
    quit. Done.


  5. #5

    Default Re: How to disable automatic updates (10.3)?

    Quote Originally Posted by GofBorg View Post
    Right click, configure. Uncheck 'automatically start at launch"
    and then ok out of it.
    Thanks, but did you fully read my first message?

    "According to the manual, the applet config should offer an "automatically start updater on login" checkbox, but mine doesn't (Gnome)."

  6. #6
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: How to disable automatic updates (10.3)?

    > (Gnome)."

    Ah, this is the part I didn't catch.
    Sorry, using Gnome that is what I would
    expect from it. It's obviously too confusing
    to have a tick box to turn it off.

    Maybe a Gnome person can guide you.



  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to disable automatic updates (10.3)?

    Quote Originally Posted by llevrel View Post
    What a light-speed answer :-)

    Disable what? I still want to be able to install new software!
    You can
    Just disable the repos
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: How to disable automatic updates (10.3)?

    Quote Originally Posted by caf4926 View Post
    Just disable the repos
    If I disable the repos, I'll have to enable them back each time I want to install a package, thus caching them again which takes much time.

    BTW, I found this in /etc/sysconfig/sw_management:
    ## Path: System/Yast2
    ## Description: Preferred package update stack if both installed
    ## Type: string(zlm,opensuse)
    ## Default: zlm
    # set to "opensuse" to use opensuse_updater as preferred update applet
    # set to "zlm" to use zen-updater as preferred update applet
    PREFERRED_SW_MANAGER_STACK="zlm"

    and I wondered which one the manual is referring to. But I couldn't find either zlm or zen-updater in the repos.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: How to disable automatic updates (10.3)?

    You said:
    Quote Originally Posted by llevrel View Post
    Hi,
    Given 10.3 has just been discontinued, there won't be any more updates. But I can't find how to disable automatic updates... According to the manual, the applet config should offer an "automatically start updater on login" checkbox, but mine doesn't (Gnome).

    I couldn't find in Yast either.

    Thanks in advance.
    Either you disable the updater applet from starting, something I always did anyway. Or you take out the Update channel - Then you'll not get any. But Updates for 10.3 has ended hasn't it?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: How to disable automatic updates (10.3)?

    Quote Originally Posted by caf4926 View Post
    Either you disable the updater applet from starting
    And how to do this is precisely the point of this thread!

    I found it finally: I uninstalled the opensuse-updater package! Sounds so obvious afterwards...

    But Updates for 10.3 has ended hasn't it?
    Yes but the updater still runs at login (and of course says the system is up-to-date!).

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •