Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Rogue gvfs processes

  1. #1

    Default Rogue gvfs processes

    I have recently moved to suse 11.3 from 9.2. I have a series of crontab scripts which do things like checking existence and permission of files (tripwire and homegrown), backup things on a second disk etc.

    Now some of those scripts (which all worked perfectly under 9.2) do hang on insufficient permissions on an empty directory ~/.gvfs which I am not at all aware of creating.

    If I try to delete it I get
    rm: cannot remove directory `.gvfs': Device or resource busy

    Looking at lsof output I find it is open to a process /usr/lib/gvfs//gvfs-fuse-daemon
    which I am not aware to start.

    More curiously, a ps output shows a number of processes (which I am not aware to start) running under my user id, all reparented to init
    1 18199 lucio /usr/lib/notification-daemon-1.0/notification-daemon
    1 18219 lucio /usr/lib/gvfs/gvfsd
    1 18224 lucio /usr/lib/gvfs//gvfs-fuse-daemon /poseidon/lucio/.gvfs
    1 20497 root dbus-launch --autolaunch bce8d279423663d4735b9a3c000003e1 --binary-syntax --close-stderr
    1 20498 root /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
    1 20730 lucio dbus-launch --autolaunch bce8d279423663d4735b9a3c000003e1 --binary-syntax --close-stderr
    1 20731 lucio /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
    1 20733 lucio /usr/lib/GConf/2/gconfd-2

    Last time I logged out and logged in again and they disappeared. But then sometimes they appeared again without me being aware of starting them.

    What is the purpose of those processes, what is starting them, and is there a way to inhibit this if they are useless (and annoying as it looks) ?


    BTW, if it matters, my window manager is fvwm.
    I also tend to leave the machine logged in during the night, locked with the xlock screeensaver.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Rogue gvfs processes

    I can add that as KDE user, I also have that directory. And it refuses to be backed up using rsync. Which isn't much to worry about, but what is it?
    Henk van Velden

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Rogue gvfs processes

    On 2010-12-29 11:06, luciochiappetti wrote:
    > If I try to delete it I get
    > rm: cannot remove directory `.gvfs': Device or resource busy


    Leave that directory alone. It is a virtual filesytem belonging exclusively
    to the user, needed by the system.

    http://en.wikipedia.org/wiki/Gvfs

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Rogue gvfs processes

    hcvv wrote:

    >
    > I can add that as KDE user, I also have that directory. And it refuses
    > to be backed up using -rsync-. Which isn't much to worry about, but what
    > is it?
    >
    >

    I also wondered sometimes when find told me it cannot read .gvfs why I need
    the gnome virtual file system on kde, everytime I forget to look up why it
    is needed. I just tested now what happens if I uninstall the gvfs packages
    (only did a dryrun so I did not really delete them) and it turned out that
    nothing depends on them.
    Sorry that I cannot give a solution, but I am also interested in the answers
    what we need it for.
    A quick google session did not tell me much about its usefullness for non-
    gnome systems :-(

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Rogue gvfs processes

    Carlos E. R. wrote:

    > On 2010-12-29 11:06, luciochiappetti wrote:
    > Leave that directory alone. It is a virtual filesytem belonging
    > exclusively to the user, needed by the system.
    >
    > http://en.wikipedia.org/wiki/Gvfs
    >

    Found that also but what is its use for other than gnome systems, we have
    not gio but kio in kde and this does not depend on gvfs - so why is it
    there.

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Rogue gvfs processes

    On 2010-12-29 14:18, martin_helm wrote:

    > Sorry that I cannot give a solution, but I am also interested in the answers
    > what we need it for.


    I don't see that anything needs to be solved >:-)

    > A quick google session did not tell me much about its usefullness for non-
    > gnome systems :-(


    Because probably you have used a gnome program.


    If you object to gvfs, open a bugzilla report.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Rogue gvfs processes

    I see something that could be solved.

    When this is intended to be more or less hidden from the user (of a program that happens to call itself a Gnome program), why then advertises it itself by generating error/warning messages when that innocent user tries to back up things from his home directory? I know of other programs that create config files and the like in ones home directory (often as so calles "hidden" ones), but they never give any problems in this aspect.
    Henk van Velden

  8. #8

    Default Re: Rogue gvfs processes

    Quote Originally Posted by robin_listas View Post
    On 2010-12-29 11:06, luciochiappetti wrote:
    > If I try to delete it I get
    > rm: cannot remove directory `.gvfs': Device or resource busy


    Leave that directory alone. It is a virtual filesytem belonging exclusively
    to the user, needed by the system.
    Well, I AM the user (as well as root of my machine) and I tend not to like the idea of having a virtual filesystem I've never asked for, or a process which starts with me being unaware of it.

    Incidentally when I logout the two gvfs processes disappear and I can remove the directory.

    When I login again under my fvwm session, there are three processes starting with my userid but without my awareness and reparented to init. They are
    dbus-launch --autolaunch ... , /bin/dbus-daemon --fork ... and /usr/lib/GConf/2/gconfd-2

    The gvfsd processes do not start at login, but at some random time later. I found for instance .gvfs reappeared today at 13:42. I tried to find what I was doing then. I found I used openoffice at 13:41, but apparently it's not the culprit (I logged out and logged in again, did a lot of little tests with openoffice, and in two hours .gvfs has not reappeared).

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Rogue gvfs processes

    Carlos E. R. wrote:

    > On 2010-12-29 14:18, martin_helm wrote:
    >
    > I don't see that anything needs to be solved >:-)
    >

    I second hcvv. The demon requests resources - I have an older netbook around
    for this a superflous demon which takes up to 30 MB is not that good (just
    checked that).

    >> A quick google session did not tell me much about its usefullness for
    >> non- gnome systems :-(

    >
    > Because probably you have used a gnome program.
    >

    No. On the two machines in my footer I could not care less and there it is
    logical to have it since both have a full gnome and a full kde environment.
    But not for a pure kde environment I test on the netbook.
    To be sure I installed now a kde live with default settings in vmware (to
    simulate what I have on the netbook) and see there is first no gvfs
    installed. On the first run of yast software management it pulls
    automatically in a lot of additional things (as usual) and it contains
    packages like fuse and gvfs and would like to understand why.

    >
    > If you object to gvfs, open a bugzilla report.
    >

    We discuss here a general question, nobody spoke about a bug here.
    From what do you read in my posts that I object against gvfs? The discussion
    is not even near to any conclusion but full of open questions.

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  10. #10

    Default Re: Rogue gvfs processes

    I found this reference in another forum. Suggests setting an environment variable during xinitrc to disable gvfs.

    But is written for a different Linux flavour. Any idea of a robust implementation of that for Suse (specially when using fvwm ? It looks like the process chain is something like this

    1 2410 root /usr/bin/kdm
    2410 2480 root /usr/bin/Xorg -br :0 vt7 -nolisten tcp -auth /var/lib/xdm/authdir/authfiles/A:0-JGo5ja
    2410 2483 root -:0
    2483 2776 lucio /usr/bin/fvwm
    2776 2966 lucio /usr/bin/ssh-agent /etc/X11/xinit/xinitrc

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •