Results 1 to 2 of 2

Thread: opensuse 11.2 xen trying to create solaris 10 guest

  1. #1

    Default opensuse 11.2 xen trying to create solaris 10 guest

    Hi,
    I just put up an 11.2 server to run xen, my hardware does NOT support full virtulization. I wanted to create a solaris 10 guest. I downloaded the dvd iso and put it local in a place with proper access. I create the guest, but when it goes to launch the installation, i get the following message:

    The installation source is unusable.

    when I run vm-install --debug, i get the following, what am i doing wrong? btw, the iso seems good, I can mount it and explore it.

    DEBUG do_progress_change: 0.38
    DEBUG do_progress_change: 0.75
    DEBUG Installation source: 2.4 GB CD-ROM or DVD (file:/media/ISO/sol10.iso)
    DEBUG Examining '/media/ISO/sol10.iso' for partitions...
    DEBUG Running: ['/sbin/sfdisk', '--force', '-d', '-uS', '--', '/media/ISO/sol10.iso']
    DEBUG Mounting a disk: ['/bin/mount', '-o', 'loop,ro', '/media/ISO/sol10.iso', '/tmp/tmp4F3bfX']
    DEBUG Running: ['/bin/mount', '-o', 'loop,ro', '/media/ISO/sol10.iso', '/tmp/tmp4F3bfX']
    DEBUG do_progress_change: 0.80
    DEBUG Unmounting a disk: ['/bin/umount', '/tmp/tmp4F3bfX']
    DEBUG Running: ['/bin/umount', '/tmp/tmp4F3bfX']
    INFO vminstall.Error caught in job.run: The installation source is unusable. (2.4 GB CD-ROM or DVD (file:/media/ISO/sol10.iso))
    INFO Installation failed, so destroying VM
    INFO Installation failed, so cleaning up disks
    INFO Deleting created disk '/var/lib/xen/images/solaris10/disk0'
    ERROR VM creation job failed: The installation source is unusable. (2.4 GB CD-ROM or DVD (file:/media/ISO/sol10.iso))
    DEBUG do_progress_close
    DEBUG do_show_error
    DEBUG _do_show_error
    DEBUG _do_show_error: error was 'The installation source is unusable. (2.4 GB CD-ROM or DVD (file:/media/ISO/sol10.iso))'
    DEBUG do_done
    DEBUG _do_done: state was 'Preparing to start the installation...'

  2. #2
    rotorek NNTP User

    Default Re: opensuse 11.2 xen trying to create solaris 10 guest

    Hello,

    I got the same problem.

    I have managed to run the Solaris's boot loader, but than it fail:

    vm-install --no-install

    configured solaris 10 (max ram was limited to 512MB)

    configured a hard drive in a file
    configured cd rom -- device pointing to a iso image

    finish


    Then in /var/lib/xen/images/<name of the machine>/xvda was missing (the name of the harddrive that I configured in the wizard.

    Created by running:

    dd if=/dev/zero of=xvda bs=1k seek=2048k count=1

    Then in /etc/xen/vm/<name of the machine> file you can specify more RAM and you have to assure that in flag disk = [ .... -- the cd rom drive is the first one.


    Then just booted using:

    xm create /etc/xen/vm/<name of the machine> -c


    Then I'm able to see the bootloader -- to choose the type of installation, but after I choose one, the virtual machine fails:

    Code:
    Traceback (most recent call last):
                                        
    File "/usr/bin/pygrub", line 660, in <module>
         chosencfg = run_grub(file, entry, fs)
                                                
    File "/usr/bin/pygrub", line 531, in run_grub
                 grubcfg["kernel"] = img.kernel[1]
                                                  
    TypeError: 'NoneType' object is unsubscriptable
                 us000604:/etc/xen/vm # Error: Boot loader didn't return any data!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •