Results 1 to 2 of 2

Thread: Weird behavior while installing/updating packages...

  1. #1

    Red face Weird behavior while installing/updating packages...

    When I run YaST2 on OpenSUSE 11.2, no matter if I'm installing or updating packages, the tool seems to run fine and suddenly quits after applying changes.

    Here come some questions:

    1. For both situations (installing and updating packages), how can I make it so that the program is not closed after the installation, so I can keep on installing other packages?

    2. About online update, if I choose for it to show all available fixes, it shows a small list of packages to be updated (around 12). Some marked with a black box, some other blank. No matter the selection I make, after I click to apply the updates, the tool finishes the updating process, and opening again the online update, the same updates are still there, like if they were not installed. Is it really supposed to behave like that?

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Weird behavior while installing/updating packages...

    Yast does close down the package manager when it's done. You can change this:
    YAST - System - /etc/sysconfig Editor:
    System>Yast2>GUI>PKGMGR_ACTION_AT_EXIT
    Choose option "restart"

    Do this in a terminal for me:

    Code:
    zypper lr -d
    and

    Code:
    zypper lu
    post result
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •