Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't read backed-up files

  1. #1
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Can't read backed-up files

    Hei,

    I am in a bit tricky situation.
    I recently installed OS11.2, earlier I was on 11.0. With the introduction of ext4 file-system I decided to re-format all my drives/partitions when 'upgrading' except for one, which I always has had as a multimedia mount on my /home/xxx directory. On OS11.0 I used kde3 now I am on kde4.
    Well, to my problem, I do not know what exactly it is but before I installed the new OpenSuSE I used the 'spare' drive as back-up. But now I am in a situation where some of those backed-up files are treated as though they aren't there anymore. Theese files are mainly audio files and I know they are allright, but there is obviously something, file-name or tagg etc, which, presumably, can't be read in kde4?? I haven't tried to move them from command line but shall do so when back at home.

    Any suggestions? Permission is allright.

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Can't read backed-up files

    Do you mean if you do the following, you don't see those files:
    Code:
    ls -l /home/xxx
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Can't read backed-up files

    No I see them allright. I browse the directory and the files are there, I try to copy them over to a new location(I copy, not move) and an error message pop-up saying: 'this file does not exist'. But the file has the expected size and is owned by me, however, when I have made that attempt to move it, it is marked by a key as if it was a permission problem. I suspect it has something to do with fonts, these files was modified on another machine without support for norwegian letters (we have three more than english) something which made the file-name containing symbols as replacement where those letters should be. This, though, wasn't a problem before.
    I can't test your command now as I'm not at home, will do it later.

    Thanks for your reply.

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Can't read backed-up files

    Some progress.

    I have now managed to play the audio files. However, I can not access them through kde, inclusive the konsole, and try to start them from there.

    This is what I did:
    I browsed the folder containing the audio files and see them all just fine; I did this with Dolphin, Konqueror and from the konsole; If I click on the file it will pop-up with an error message stating that the file does not exist; when I do this the file will be displayed with a key, as if it was a 'permission denied' file and I have to restart Dolphin (or Konqueror) to re-set the file from its 'locked' status. Next, I re-opened the same location, I tried to access the same file, but this time I chose open with and selected audacity. Again, an error message pop-up saying: 'error when loading.....(something)'. I then took a different approach, I open Audacity, chose: file > open > 'the same audio file as above', voila! there it is, quite fine and playable.

  5. #5
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Can't read backed-up files

    I had a similar problem within another location on the back-up HD. This time it was with a folder, containing audio files. I could not enter it and, furthermore, it was displayed and estimated as empty by Dolphin. I even thought it had to be so, as I tried to go further out in the directory tree to see if the expected size of the folder were estimated into the total amount there. And, according to what mentioned previously, I restarted dolphin to see if things (the size) changed, still the same. This was different to how Dolphin and Konqueror behaved towards the files directly, all of the audio files in the directory, mentioned previously, was displayed and estimated with the correct size. That is to say: everything with the file was apparently correct until trying to activate the file. Not so with the folder example. I also tried to enter the folder from Konsole whitout any luck: 'There is no such directory (...).'. But, again, browsing through audacity shows clearly that the files stored in the 'non-existing folder' are there. They are accessible and playable.

    A sollution, thus, is to open every ****ing file with Audacity, resample, convert or just rename or re-tag, or something else(?), and save them in the directory where they initially were (before being backed-up). I have not explored further what the possible cause more preciesly could be, but, as I mentioned previously, fonts, wether it was far fetched or not, is not the issue it seems, as I had several other both folders and files whose name included those letters. There was no problem copying (accessing++) them.

    I haven't really got a clue, but it seems likely to me that it has its origin in kde4 possibly qt4? I never had this problem in kde3. I am probably a bit biased and, perhaps unreasonably, sceptic towards kde4. I do not think I had changed desktop if kde3 had been developed further. However, kde4 looks splendid, lets hope all the(my) greatly missed applications, Kaffeine and Amarok will be back on form soon.

    Well thanks for reading, and comment if you want to. A bit strange if I am the only one who experience this, well well.

    Cheers

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Can't read backed-up files

    Yes, unusual. Did you check your localization and encoding settings in Yast>System>Idiom/language? Is UTF-8 enabled? Also the language settings in kde control center?

  7. #7
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Can't read backed-up files

    Hello,
    Also the language settings in kde control center?
    Could this cause a conflict?
    In any case the language setting both local and global are the same as I had them in 11.0 and kde3.

    I don't know about UTF-8 but will check it. I don't know what it is either?

    Thanks

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Can't read backed-up files

    Hum... fstab mount options maybe? Take a look here: Codepage Problem? - openSUSE Forums

    UTF-8 is the standard character encoding in openSUSE: see http://en.wikipedia.org/wiki/Utf-8

  9. #9
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Can't read backed-up files

    Thanks.

    Yes, that and a few more symbols like it are the replacements for these letters in the files which are considered non-existing by kde. However, it is not a regular pattern of behaviour. Some files with these replacements are treated just fine. And I should point out that these symbols do just occur in files which are edited on machines with lack of support for these letters.

    I think I usually used dejavu fonts with kde3, I do not quite remember which font I have configured kde4 to use, a libertine font I believe. But in any case all the symbols in the norwegian alphabet are supported.

    UTF-8 is enabled.

    I will check the fstab mount options.

    Cheers

  10. #10
    JosephKK NNTP User

    Default Re: Can't read backed-up files

    On Mon, 07 Dec 2009 13:06:01 GMT, F Sauce
    <F_Sauce@no-mx.forums.opensuse.org> wrote:

    >
    >Thanks.
    >
    >Yes, that and a few more symbols like it are the replacements for these
    >letters in the files which are considered non-existing by kde.
    >However, it is not a regular pattern of behaviour. Some files with these
    >replacements are treated just fine. And I should point out that these
    >symbols do just occur in files which are edited on machines with lack of
    >support for these letters.
    >
    >I think I usually used dejavu fonts with kde3, I do not quite remember
    >which font I have configured kde4 to use, a libertine font I believe.
    >But in any case all the symbols in the norwegian alphabet are
    >supported.
    >
    >UTF-8 is enabled.
    >
    >I will check the fstab mount options.
    >
    >Cheers


    Each mountable volume normally has a character set associated with it.
    If you changed languages on the machine you could then have a volume
    related character set issue.

    Just for grins, try looking at the output of -sudo mount-

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •