Results 1 to 10 of 10

Thread: Wicd messed up my boot process

  1. #1
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Wicd messed up my boot process

    Hi,
    I'm running OS11.1 with Gnome on my laptop with Intel's 3945 wireless card. Like many others I've been having problems with networkmanager not seeing my wifi connection from time to time, even refusing to connect to it manually (and even refusing to connect to the wired network!)

    So I tried installing wicd. I followed the procedure described in the wiki to install it, but when I rebooted I kept receiving an error saying that "Could not connect to wicd's D-Bus interface. Check the wicd log for error messages".

    Then I found a suggestion somewhere on the internet (sorry, can't find the link anymore) saying that this message was related to the fact that the wicd service was not started properly during boot and suggested checking that wicd was started at runlevels 2, 3 and 5 (so I went into Yast->System Services and modified this). This effectively stopped the D-Bus error from showing up, but it introduced a new problem:

    during the boot sequence I started receiving the error "failed" at the start of DHCP4 client, and (bigger problem) boot freezes a few lines later, at the "Starting NFS client services: sm-notify idmapd" step.
    It stays there three or four minutes, then boot resumes. I can't understand why this happens.

    Any suggestions on how to solve this?
    Thanks

  2. #2
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Wicd messed up my boot process

    Did you go on and follow the Usage part of that wiki? Wicd - openSUSE
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

  3. #3
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Re: Wicd messed up my boot process

    Yes, of course. I followed it all to the part with the following commands:

    Code:
    sudo /sbin/chkconfig network on
    sudo /sbin/rcnetwork start
    Then I stopped, since the tutorial says "OR", and I imagined that this means to stop there if the previous part did not output any error. Am I wrong?

  4. #4
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Re: Wicd messed up my boot process

    BTW, I've found the link that suggested changing the runlevel of the wicd service. HERE it is.

  5. #5
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Wicd messed up my boot process

    Quote Originally Posted by Sciamano View Post

    during the boot sequence I started receiving the error "failed" at the start of DHCP4 client, and (bigger problem) boot freezes a few lines later, at the "Starting NFS client services: sm-notify idmapd" step.
    It stays there three or four minutes, then boot resumes. I can't understand why this happens.
    Thanks
    This bit bothers me. I don't have DHCP4 listed at all, and mine works just fine. It almost sounds like you were messing with DHCP client and sever configurations.

    I have nfs enabled, but not nfsserver, and since it's talking about client, again, that makes me think you were messing with the nfs server and client configurations.

    sm-notify idmapd is part of the nfs client.

    This would mean you went outside the wiki and did things the wiki didn't cover, and are not mentioning it in your request for help.

    The good news is, I may have found the solutions here openSUSE News openSUSE 11.1 Released!

    run your system with “single” option which start ur system in directly shell
    and then just check the configuration using “chkconfig” command..
    It will show you the list of different configuration which is on or off..
    Now as we are having problem with NFS Server just closed it with command..
    linux:~ # chkconfig nfs
    nfs on
    Now ….
    linux:~ # chkconfig nfs off
    nfs off
    now just reboot the sytem…
    linux:~ # reboot
    now your system will reboot and will work fine…
    Your problem is resolved…
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

  6. #6
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Re: Wicd messed up my boot process

    Quote Originally Posted by Jonathan_R View Post
    This bit bothers me. I don't have DHCP4 listed at all, and mine works just fine. It almost sounds like you were messing with DHCP client and sever configurations
    I uninstalled networkmanager at first, and when I had all these problems I had to reinstall it because with wicd not working I couldn't connect to the network at all.
    During these procedures I might have accidentally made a wrong change in the Yast->Network "pages", when trying to re-enable NetworkManager, but honestly I don't remember touching any setting regarding DHCP. Then I've then tried wicd again, and I followed the procedures explained in the wiki a second time.

    I have nfs enabled, but not nfsserver, and since it's talking about client, again, that makes me think you were messing with the nfs server and client configurations.
    I only set up a few NFS folders to be mounted at startup, but nothing complicated: just added a few lines to the fstab. I don't recall entering any advanced settings nor installing anything in particular.

    sm-notify idmapd is part of the nfs client.

    This would mean you went outside the wiki and did things the wiki didn't cover, and are not mentioning it in your request for help.
    I'm not hiding anything, I swear!
    I guess the nfs client is needed if I want to mount nfs shares, so I cannot uninstall it. But I could probably try uninstalling the nfs server if it is not needed.

    The good news is, I may have found the solutions here openSUSE News openSUSE 11.1 Released!
    Thanks, I'll try this and report here immediately after.
    Last edited by Sciamano; 01-Dec-2009 at 05:47. Reason: typo

  7. #7
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Re: Wicd messed up my boot process

    It worked! Thanks!!
    Now boot time is almost back to normal, except for the small delay due to the DHCP4 client problem. If only I could solve this too...

  8. #8
    Join Date
    Oct 2009
    Location
    Milano, Italy
    Posts
    35

    Default Re: Wicd messed up my boot process

    This is the exact output at boot:

    Code:
    Setting up (localfs) network interfaces:
        lo        
        lo        IP address: 127.0.0.1/8   
                  IP address: 127.0.0.2/8   
        lo       
    done    eth0      device: Intel Corporation PRO/100 VE Network Connection (rev 02)
        eth0      Starting DHCP4 client. . . . .  
        eth0      DHCP4 client NOT running
        eth0     
    failedWaiting for mandatory devices:  eth0 __NSC__
    17 16 15 13 12 11 10 9 7 6 5 4 2 1 0 
        eth0      device: Intel Corporation PRO/100 VE Network Connection (rev 02)
        eth0      DHCP4 client NOT running
        eth0     
    failed    eth0      interface could not be set up until now
    failedSetting up service (localfs) network  .  .  .  .  .  .  .  .  .  .failed

  9. #9

    Default Re: Wicd messed up my boot process

    I just ran into this "DHCP4 client NOT running" issue today and couldn't find a solution on it in the forums. Fortunately a coworker and I were able to figure out what was going on behind the scenes and fixed it(for us)!!!


    • What is the Problem?
      • The script handling starting the DHCP process for your interfaces is being called with incorrect parameters.
      • Further Explanation:
        • When all the various network scripts are called, /sbin/dhcpcd is called to turn on dhcp service for the specified ethernet port.
        • dhcpcd expects very specific parameters and has very little in the way of debugging the problems themselves.

    • How to Fix it?
      • There was an issue with my hostname, I presume the same can be said for your machine.
        • myhostname was: root@server
        • See that "@" symbol? Well the DHCP server isn't going to handle that quite right and so dhcpcd says "err, suspect string in hostname argument". That was the puzzle piece that put it all together for me.
        • So just change your hostname and all will be well.


    Process to figure it out:

    I did an strace:
    Code:
    server:/etc/sysconfig/network # strace -s 1024 -o foo -f /sbin/ifup-dhcp eth0 eth0
    from within the strace i found this line:
    31194 execve("/sbin/dhcpcd", ["/sbin/dhcpcd", "--netconfig", "-L", "-E", "-G", "-c", "/etc/sysconfig/network/scripts/dhcpcd-hook", "-t", "120", "-h", "root@server", "eth0"], [/* 70 vars */] <unfinished ...>
    so I tried to run the dhcpcd call manually:
    Code:
    server:/etc/sysconfig/network # /sbin/dhcpcd "--netconfig" "-L" "-E" "-G" "-c" "/etc/sysconfig/network/scripts/dhcpcd-hook" "-t" "120" "-h" 'root@server' "eth0"
    and got this back:
    eth0 device: Intel Corporation I350 Gigabit Network Connection (rev 01)
    err, eth0: Failed to lookup hostname via DNS: Name or service not known
    eth0 device: Intel Corporation I350 Gigabit Network Connection (rev 01)
    and when I checked ifconfig eth0:
    Code:
    root@server:/etc/sysconfig/network # ifconfig eth0
    eth0 Link encap:Ethernet HWaddr B8:CA:3A:68:34:70
    inet addr:39.80.8.12 Bcast:39.95.255.255 Mask:255.240.0.0
    inet6 addr: fe80::baca:3aff:fe68:3470/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:24538 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3537 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2978118 (2.8 Mb) TX bytes:951302 (929.0 Kb)
    so, to make sure it doesn't happen every time "ifup" is called:
    Code:
    server:/etc/sysconfig/network # echo "server" > /etc/HOSTNAME 
    server:/etc/sysconfig/network # hostname server
    server:/etc/sysconfig/network # ifdown eth0
    server:/etc/sysconfig/network # ifup eth0
    eth0 device: Intel Corporation I350 Gigabit Network Connection (rev 01)
    Starting DHCP4 client on eth0. . . . . .
    eth0 IP address: 39.80.8.12/12
    Hooray!!!!

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,293
    Blog Entries
    1

    Default Re: Wicd messed up my boot process

    All well and good, but this is thread is over 6 years old, and should not have been tacked on to like this. I'll close this thread accordingly.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •