Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome 2.x

  1. #1

    Default Power management (screen saver) Suse 11.2 KDE4.3 & Gnome 2.x

    I have disabled the screensaver in both Gnome and KDE. It still blanks my screen and locks it after approximately 10 minutes. This makes movie watching rather annoying.

    Have tried setting the screen saver to hit after 2.5 hrs, still makes no difference. I told it not to require a password when it does hit and it locks it everytime; instantly.

    I'm at a loss. Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    System Settings
    Display
    Power Control (Uncheck display power management)
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    Quote Originally Posted by caf4926 View Post
    System Settings
    Display
    Power Control (Uncheck display power management)
    Disabling it or setting it to hit at 2.5 hrs and it still hits at about 10 minutes, I have the check box for NOT locking the screen and it locks instantly.

    I have it shut off and it's still active. Why?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    You need to go through the power management section (in kde anyway) and each and every part of it and check no power management is checked and disable the screensaver totally. It will work if you find all the variations. It's a pain for sure.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    Quote Originally Posted by caf4926 View Post
    You need to go through the power management section (in kde anyway) and each and every part of it and check no power management is checked and disable the screensaver totally. It will work if you find all the variations. It's a pain for sure.
    Finally just shut off the power devil service. That's the only fix I've found. Really looking at going back to KDE3.5 with Suse11.1. The eye candy is not worth the other headaches of KDE4.3. If I wanted Vista, I woulda left it on the computer when I got it.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    I wouldn't recommend kde3 now. Go to Gnome it's beautiful
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,289
    Blog Entries
    1

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    What does this terminal command report?
    xset q |grep DPMS
    If DPMS enabled, try disabling with
    xset -dpms
    This thread for more info.

  8. #8
    lazerweb NNTP User

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    I am having the same problem in Gnome / suse 11.2...the system powers back to the login screen and it is literally driving me nuts! Power management gives hardly any options...

  9. #9

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    Quote Originally Posted by caf4926 View Post
    I wouldn't recommend kde3 now. Go to Gnome it's beautiful
    Not from my prespective, but I am using it a bit more now so who knows. Fluxbox is nice and light, but haven't used it in years.

  10. #10

    Default Re: Power management (screen saver) Suse 11.2 KDE4.3 & Gnome

    I have found the little gremlin in my case

    I changed all sorts of settings for ages and only just took up the issue again.

    I found the solution as follows:

    Open your system settings window. If you look at the top of the window you will see a tab labeled advanced, click on it and then on the lower half you will see system... under that section there is an option to edit your Power Management. In GENERAL SETTINGS you will see tick-boxes for locking the screen on resume and an option for powerdevil. (I unticked these)

    Take note of the different profile option in the lower half of this page (PROFILE ASSIGNMENT), mine is set to PERFORMANCE when plugged in etc.

    Now in the left pane you will see an icon for EDIT PROFILES. Under this menu you will see the different options you have under each profile. Under each profile there is on option to take an action after the system has been idle for XXX minutes, mine was set to lock the screen after 15 min which kept overriding any other setting I wanted. By changing this to DO NOTHING it solved the issue for me. Look specifically at the profile you have as default but be careful to change the others if you need to.

    Cheers all

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •