Results 1 to 4 of 4

Thread: OpenMPI from Pacman not working?

  1. #1
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default OpenMPI from Pacman not working?

    I tried installing OpenMPI from Packman (I need specifically OpenMPI for some software I'm using) - but the executables and libraries don't seem to get appended to the path or libpath - can anyone tell me how to do this? I'm not going to be compiling the code, I just need the right mpirun to be called and .so files available...

    Thanks!
    Patti

  2. #2

    Default Re: OpenMPI from Pacman not working?

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    export LD_LIBRARY_PATH=/path/to/your/files/:$LD_LIBRARY_PATH
    export PATH=/path/to/your/binaries/:$PATH #optional I imagine
    mpiCommand

    Good luck.




    PattiMichelle wrote:
    > I tried installing OpenMPI from Packman (I need specifically OpenMPI for
    > some software I'm using) - but the executables and libraries don't seem
    > to get appended to the path or libpath - can anyone tell me how to do
    > this? I'm not going to be compiling the code, I just need the right
    > mpirun to be called and .so files available...
    >
    > Thanks!
    > Patti
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJLFHQQAAoJEF+XTK08PnB55JsP/3iBlahsyc4HW52GBeaIGgkM
    /DhDUokcUzXI2d5sBhXdxEFj577zWiRdUYkfI4iEG9ubCsJKLB1hzLbv5sgYUsWZ
    M5b8QCPjQKkQvc9ELpw5ovKYbXg+bbjVSvJyUC8Jikfkv9c7wpQtePtPnyVVa8S+
    51lg+fswTe2FgPvE3XqEpJqhpqIyIf0ZnXqOUhh0wm8Sam1SiLvnSDYEHcveQduK
    iE+plO+lbilfCBaX8oyVxn/R9cQtbOHsMnSXrctfstPlbLvV3pgM4buS/go5Yp4U
    BvNt+ak/FJV8Ewtr2q5hpmBYUpyqsaeXRslEndNzjclNHAUA5ksCn5gZlSkCLTEZ
    U10WzOwjIqDkzVj7Mjq5yEfUaOQ698MNgn70FSyo+1VuE38Qo/iCY0siW93b3SiW
    mR1DEh3etHOaHRgPKUVTTodUGs8unH7PzVrOet918Wmd4el2atsFfTXh56RtLMSP
    pN2F3nJP0MkH+eEPYos4bwsExh0Ahics2PrC955Pjn5zYOfegKdW+Bhy4kLyMAww
    OSj6jkbRc0NaUF90LL4dBLcB03RYLqKS5IFmdc6R8ziJjlBuLvZWxMSx8wNUa9Ow
    HNt4cZkz9RkhKAga7kkt8PHtIWV4iI/L9AG4UKNltUfBuGcfH8jdKkrFyhGmG2Sn
    KkXLWyQHGNOEoCbmqMgr
    =3CWU
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: OpenMPI from Pacman not working?

    Thanks, I'm just getting back to that problem and I'll give it a try. When I do full referencing of /.../mpirun it works OK. But I don't know at what point other libraries get used and they're not directly referenced in the call to mpirun.

  4. #4
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: OpenMPI from Pacman not working?

    Not working!

    SOCRATESP5.0.2a_DISTRIBUTION_C/test_cases> export LD_LIBRARY_PATH=/usr/lib64/mpi/gcc/openmpi/lib64/:$LD_LIBRARY_PATH
    LD_LIBRARY_PATH: Undefined variable.
    SOCRATESP5.0.2a_DISTRIBUTION_C/test_cases>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •