Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Google Calendar with akonadi and korganizer

  1. #1

    Default Google Calendar with akonadi and korganizer

    Dear All,

    I am trying sync a google calendar to korganizer using the new libgcal and akonadi googledata packages.

    First of all I should state that I am using the KDE packages from the following repository (KDE 4.3.3):

    Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2

    Furthermore, I am adding the libgcal0 and akonadi-googledata packages from this repository:

    Index of /repositories/home:/gryffus/openSUSE_11.2+KDE4_Factory

    But I also tried to compile libgcal myself from the git repository. For the rest, it is a normal 11.2 distro.

    Now, when I go to the Akonadi configuration and try to add a Google Calendar resource, I fill in my name and password. Then, immediately, the akonadi configuration tools shows it with a "invalid password" message.

    I googled around and I found this to be a problem with libgcal. However, it should be fixed in version 0.93, which I am using. And anyway, even if I compile the latest version from git I get the same problem

    Is anyone else experiencing the same?

    Thanks

    Valerio

  2. #2

    Default Re: Google Calendar with akonadi and korganizer

    Upon further research, I realized the problem must be tied to this bug:

    https://bugs.kde.org/show_bug.cgi?id=204165

    However, I am using the same libraries of the person who solved the problem (0.93 for libgcal and 1.0.1 for akonadi-googledata)

    Valerio

  3. #3

    Default Re: Google Calendar with akonadi and korganizer

    Well, people on other distributions seems to be syncing fine. So I guess this must be a bug with OpenSUSE 11.2 In fact several people are reporting it using OpenSUSE.

    Even compiling google-akonadi and libgcal from source is not working


    Valerio

  4. #4

    Default Re: Google Calendar with akonadi and korganizer

    Just as a test I tried to use this in a Kubuntu box, and there it works perfectly. So this is defenitely an OpenSUSE bug. Can someone please point me to the way of submitting it?

    Valerio

  5. #5
    Join Date
    Jul 2008
    Location
    Nottingham, UK
    Posts
    37

    Default Re: Google Calendar with akonadi and korganizer

    You'll want to go here, create an account and fire away.

  6. #6
    Join Date
    Dec 2009
    Location
    Balingen
    Posts
    9

    Lightbulb Re: Google Calendar with akonadi and korganizer

    I've had the same problem with OpenSUSE 11.2. By analyzing the strace-output of google-akonadi I've found a problem with the proxy-handling.

    It seems, that by default, Opensuse 11.2 uses environment variables for the proxy-settings .

    So entering "network settings -> proxy" and changing the default setting to "direct connection with the internet" solved this problem for me and everything works fine

  7. #7

    Default Re: Google Calendar with akonadi and korganizer

    I found the setting you are mentioning and tweaked it. It works for me also. Thank you very very much!

    Valerio

  8. #8

    Default Re: Google Calendar with akonadi and korganizer

    I'm sorry, but I'm still a bit confused. Which settings am I exactly supposed to alter? I couldn't find something similar in Yast or NetworkManager.

  9. #9

    Default Re: Google Calendar with akonadi and korganizer

    OK, when looking longer than 2 seconds I found it in the KDE settings. Thanks, solved the problem! It also solved the problem that Firefox could not connect to the outside world (which was worked around by setting the proxysettings in Fx manually)

  10. #10
    Join Date
    Jan 2010
    Location
    Munich, Germany
    Posts
    22

    Default Re: Google Calendar with akonadi and korganizer

    Changing that proxy stuff fixed it for me too, thanks!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •