Results 1 to 9 of 9

Thread: "Nothing Provides blah blah" issues 11.2

  1. #1

    Default "Nothing Provides blah blah" issues 11.2

    It's been a while since I came here for help, usually I find a solution for myself, and whilst it might not be the quickest way to solve problems, it's certainly helped me get a little better understanding of suse.

    Since upgrading to 11.2 64bit though (from 11.1 64bit), some things are mysteriously unforgiving, and resolution eludes me. I wanted to install the new version of wine, so after adding the repo went to software management and clicked for the latest version. It told me that nothing provided libopenal.so.1. No biggie, seen this kind of thing a thousand times, figured that after upgrading, it was one of the things that got deleted. A quick google and I'm installing libopenal1-soft. When I click on that and look at dependencies tab I see that it provides libopenal.so.1.
    Wine doesn't think so, as trying to install the newer version still tells me that "Nothing provides libopenal.so.1"
    I tried removing the old wine, and as soon as I click the tick next to it, I get the same message.
    In the end I gave up.

    I'm a musician, and today I decide to see if there's any audio software worth using. A little old synth emulator called Bristol caught my eye, and after searching for a suse 11.2 rpm for it, came up with something on the packman site with a one click install for 11.2 64bit.
    Can't say fairer than that, every time I ever used one click install before, was never anything I had to do except wait.
    Not this time, after it showed me all the changes etc and I'd clicked yes do it etc, I get "Nothing provides Jack".
    I look up Jack on google, and after a while reach a download page that says "Use your package manager to get this".
    I type Jack in the search bar in yast, and find all kinds of things with the name Jack in the name, but checking the dependencies tab, see that none provide anything just called "Jack". LibJack0 and libjack0 32 bit are checked, but neither appear to provide Jack.

    These are just 2 examples that I've been unable to resolve, there are many more. Dependencies that I'm either not able to find in yast, not able to find in google, or that I've found and installed, yet still told that "Nothing Provides blah"

    I could care less about the other things, but libopenal.so.1 seems pretty necessary to a lot of things I try to install, and if I want to check out audio software stuff, Jack seems pretty important too.
    If someone can explain the error of my ways and what it is I should be doing, I'd be much obliged.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: "Nothing Provides blah blah" issues 11.2

    I'm running OS 11.2_x86_64, KDE.

    I ran into a similar problem when installing Wine for 11.2. My problem was Yast couldn't find a package named "orange" for Wine-doors and that jammed up my install this morning.

    Try the Yast --> Package Search option in the Yast control center. That's what helped me find the package I needed. Turned out the package was in another repo I didn't have set up in Yast. Followed the onscreen directions and got what I needed.

    Hope this helps.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: "Nothing Provides blah blah" issues 11.2

    It reads to me that you do not have your software repositories set up correctly. To avoid dependency problems, I recommend 4 and only 4 repositories. No others. None. Just these 4: OSS, Non-OSS, Update and Packman. There is guidance here for how to add those 4 on openSUSE-11.2: Repositories/11.2 - openSUSE-Community Again, just those 4. Its possible OSS, Non-OSS, and Update are already added, but given your problem with libopenal.so.1 which is in the OSS repository, I think you have a problem in your setup.

    Now if you wish to add another repos for the latest wine, then my recommendation is to add it, and then immediately remove it after installing wine.

    This is INCREDIBLY quick and easy to do. I typically type:

    zypper ar <-some-repos-url-> <-aribitrary-name-i-picked-> #add repository

    zypper install <-my-desired-application->

    zypper rr <-aribitrary-name-i-picked-> #remove repository


    For example, one types "wine" in webpin and gets this hit: Webpin search for wine

    Lots of wine versions. Lets say one decides to go to the wine repos:
    Code:
    http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.2/
    Then the commands are:
    Code:
    zypper ar http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.2/ wine-repos
    Code:
    zypper install wine
    Code:
    zypper rr wine-repos

  4. #4

    Default Re: "Nothing Provides blah blah" issues 11.2

    I'm such a tard. Soon as I saw the repos listed, I remembered that during the upgrade, it told me about repos that I might want to remove, and as they were pointing at 11.1 I indeed had the installer remove them, and just point blank forgot all about them, instead after successfully upgrading, poking around to see what had changed.

    Problem solved. I love you Mr OldCPU

  5. #5

    Default Re: "Nothing Provides blah blah" issues 11.2

    One of the issues I have with openSUSE is that its still terrible with dependencies sometimes, and it wont resolve those dependencies for you.
    In Ubuntu I can download a .deb from the net, or in Mandriva download a .rpm from the net and if the package needs to install extra packages it will download and install dependencies for me as long as those dependencies are in the repositories.
    But i have to manually install dependencies in openSUSE separately from the package.
    A good example of this is realplayer 11... in openSUSE you need to install LSB separately first then install realplayer, meanwhile in both mandriva and buntu lsb and the other dependencies are installed alongside of realplayer.
    The only major time I need to install dependencies separately in buntu is if its not in a repo I have.
    Like on getdeb.

  6. #6

    Default Re: "Nothing Provides blah blah" issues 11.2

    This does seem something that could be resolved without too much effort, maybe not though, maybe that's why it can be very frustrating.

    I've found myself having to fulfill a dependency on some things, that in themselves require me to fulfill some dependencies. Since the software is able to tell you which dependency is required, doesn't seem such a stretch that during the attempted install, it couldn't search your repos and add the requirements automagically. That seems to be what the "one click install" thing does whenever you are lucky enough to find it.

  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: "Nothing Provides blah blah" issues 11.2

    Quote Originally Posted by Wibbly View Post
    This does seem something that could be resolved without too much effort, maybe not though, maybe that's why it can be very frustrating.

    I've found myself having to fulfill a dependency on some things, that in themselves require me to fulfill some dependencies. Since the software is able to tell you which dependency is required, doesn't seem such a stretch that during the attempted install, it couldn't search your repos and add the requirements automagically. That seems to be what the "one click install" thing does whenever you are lucky enough to find it.
    You could easily make a workaround for a lack of a one-click installer. Just create a folder that holds the rpms you download. Set that folder up as a repository. Whenever you download an rpm from the internet, just save it to the rpm folder repository then open Yast and search for it. Yast can then automatically get the dependencies for you, provided they're in one of your repositories.

    I had to do this before when one of my packages required the other package to be installed... which also required the first package I wanted to install, to be installed. Just put them both into a local rpm repository and then yast accepted them.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  8. #8

    Default Re: "Nothing Provides blah blah" issues 11.2

    Quote Originally Posted by ijbreakey View Post
    You could easily make a workaround for a lack of a one-click installer. Just create a folder that holds the rpms you download. Set that folder up as a repository. Whenever you download an rpm from the internet, just save it to the rpm folder repository then open Yast and search for it. Yast can then automatically get the dependencies for you, provided they're in one of your repositories.

    I had to do this before when one of my packages required the other package to be installed... which also required the first package I wanted to install, to be installed. Just put them both into a local rpm repository and then yast accepted them.

    Take Care,

    Ian
    I might consider that one myself for my hubby who is using openSUSE as his primary, like I said its kind of a pain to install some packages in openSUSE as dependencies are not installed alongside packages...
    Wish they were, would make things easier.
    With OS 11.2 being so new a lot of packages are not there yet.
    And I wish YMP installers from older versions worked too.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: "Nothing Provides blah blah" issues 11.2

    Quote Originally Posted by TaraIkeda View Post
    One of the issues I have with openSUSE is that its still terrible with dependencies sometimes, and it wont resolve those dependencies for you.
    I don't have a problem here with openSUSE dependency resolution. No problem. I keep my repos clean and mean, and it just works for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •