Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Evolution is missing some icons in 11.2

  1. #11
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Evolution is missing some icons in 11.2

    That's another good lead to solving the mystery!
    I can tell you why the next day it was OK: you probably ran an update or installed a package. You have to run SuSEconfig as root to apply those icon changes.

    With your tip, I got the Send/Receive button, but there's a whole whack of them still missing.

    However, I did not have a 'tango' folder in my /usr/share/icons. I assume you installed the icon-theme-tango. Did you do that on purpose, or was installed by something else?
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  2. #12
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Evolution is missing some icons in 11.2

    I FINALLY found a workaround for this!

    In essence, what's happening is that KDE is trying to impose its Oxygen theme on Evolution and this theme lacks the proper icons. You can either try to merge all the /usr/share/icon/gnome icons with the usr/share/icon/oxygen and then run SuSEconfig (NOT TESTED, try at your own peril).

    Or, give up on this fight and tell KDE to not impose any theme mapping:
    put an empty, hidden file called .no-qtrc-to-gtkrc-mapping in your home folder:
    Code:
    cd
    touch .no-qtrc-to-gtkrc-mapping
    This will make Evolution look like it's run in a GNOME setting and all icons are there!
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  3. #13
    Joris_M NNTP User

    Default Re: Evolution is missing some icons in 11.2

    After installing the send/receive icon I'm only missing (that I noticed) two or maybe three icons. These are located in calendar/tasks/memos. I think the better solution for me would be to solve these view missing icons (as disabling kde theming for gnome/gtk will also effect firefox).

    regards,

    Joris

  4. #14
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Evolution is missing some icons in 11.2

    If it doesn't bother you, I guess you're all set, but I had a ton more missing - click the dropdown next to the "New" button on the main toolbar, for example. Also, the icon for "Meeting request" is missing, etc. etc.

    And since I hardly use Firefox anymore (Chrome all the way), I'm OK with Firefox being a bit "bulky".

    I'm not too impressed with the response on this bug in the Novell Bugzilla. It's a heavily sponsored Novell product and there is absolutely no response to this, even though it was identified as a problem in the pre-releases.

    Ironic, isn't it - a Novell sponsored product that doesn't work on KDE - the "preferred" Window Manager for openSUSE - wait! also a Novell sponsored initiative.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  5. #15
    Joris_M NNTP User

    Default Re: Evolution is missing some icons in 11.2

    Hi,

    Finally found a better solution. I create a symlink from the directory /usr/share/icons/gnome/16x16/stock to /usr/share/icons/oxygen/16x16/stock and from the directory /usr/share/icons/gnome/32x32/stock to /usr/share/icons/oxygen/32x32/stock. After this I ran SuSeconfig and this solved the missing icons problem for me

    regards,

    Joris

  6. #16
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Evolution is missing some icons in 11.2

    Quote Originally Posted by Joris_M View Post
    Hi,

    Finally found a better solution. I create a symlink from the directory /usr/share/icons/gnome/16x16/stock to /usr/share/icons/oxygen/16x16/stock and from the directory /usr/share/icons/gnome/32x32/stock to /usr/share/icons/oxygen/32x32/stock. After this I ran SuSeconfig and this solved the missing icons problem for me

    regards,

    Joris
    Thanks - I'll give that a try.

    Would anyone know why there is no "stock" icons in the oxygen theme? Are those GNOME only icons perhaps? Or were they simply missed?
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  7. #17

    Default Re: Evolution is missing some icons in 11.2

    Evolution works just great in Gnome.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •