Results 1 to 6 of 6

Thread: Screensaver under kde does not start

  1. #1
    Join Date
    Nov 2009
    Posts
    11

    Default Screensaver under kde does not start

    Hello,

    Under suse 11.2 and kde 4.3.1 the configured screensaver does not automatically start . In control center I checked autostart in 2 minutes. But nothing...

    The power settings are all as after the fresh installation.

    xset q says:

    Keyboard Control:
    auto repeat: on key click percent: 0 LED mask: 00000002
    auto repeat delay: 660 repeat rate: 25
    auto repeating keys: 00ffffffdffffbbf
    fadfffefffedffff
    9fffffffffffffff
    fff7ffffffffffff
    bell percent: 50 bell pitch: 400 bell duration: 100
    Pointer Control:
    acceleration: 30/10 threshold: 4
    Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 0 cycle: 600
    Colors:
    default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
    Font Path:
    /usr/share/fonts/misc:unscaled,/usr/share/fonts/75dpi:unscaled,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/Type1,/usr/share/fonts/URW,/usr/share/fonts/Speedo,/usr/share/fonts/cyrillic,/usr/share/fonts/truetype,/usr/share/fonts/misc:unscaled,/usr/share/fonts/truetype/,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled,built-ins,/home/cb/.fonts
    DPMS (Energy Star):
    Standby: 0 Suspend: 0 Off: 0
    DPMS is Enabled
    Monitor is On
    Font cache:
    Server does not have the FontCache Extension

    Tried different screensavers without success.

    Any clues? Debugging possibilities, known bugs, etc?

    Thank you!

    Chris

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Screensaver under kde does not start

    The screensaver is usually an issue for users to switch the darn thing off! It does work and I am not aware of bugs.
    Personally I avoid it like the plague, after install I turn all that screen saving and power saving rubbish off.

    To your issue: What happens when you press the Test button.
    You know the screensaver will only start if the computer is idle?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2009
    Location
    Mnchen
    Posts
    295

    Default Re: Screensaver under kde does not start

    Did you set something different in Display or Energy Management in the Control Center?

  4. #4
    Join Date
    Nov 2009
    Posts
    11

    Default Re: Screensaver under kde does not start

    With fresh kde user settings (added a new user), specifically with 7 13 19 and energie saving enabled in control panel -> advanced -> system management -> display -> energy control the screensaver works as desired. However entering 0 0 0 (deactivated) with energy saving enabled seems to trigger the saver not to start.

    Why are there such dependencies to the automatic start of the screen saver? This is a bug, if you are asking me.

    Sorry for the imprecise naming of the control elements, I see them currently only in german.

    Thanks again,

    Chris

  5. #5

    Default Re: Screensaver under kde does not start

    Check
    launcher > Look & Feel > Screen Saver : Start Automatically, After ? min.
    launcher > Computer Administration > Display > Power Control : Enable display power management, Standby after ? min.

    Both of mine were set at 7 minutes. So in 7 minutes my monitor would go blank.

    Set standby to a LARGER number than you set your screen saver to start.

    I'm just glad I figured this out before I placed a bug report ;-)>

  6. #6
    Join Date
    Nov 2009
    Posts
    11

    Default Re: Screensaver under kde does not start

    > Set standby to a LARGER number than you set your
    > screen saver to start.
    This behavior is as desired and clear. If the display is off, then no screen saver needs to start.

    But having in 'launcher > Computer Administration > Display > Power Control : Enable display power management' checked, i.e., power management enabled and all timeouts set to 0 as described in my last posting, the screen saver does not start. 0 should have the special meaning of 'never' and this is per definition larger than my screen saver timeout of 5 minutes.
    As implemented, this is a BUG in KDE 4.x in my opinion:
    The screen saver starter should treat a timeout of 0 as 'never' and do not something like a simple > comparison.
    KDE 3.x, e.g., in opensuse 10.3, works as desired

    As a workaround I have unchecked 'Enable display power management' and thus DPMS completely set to off. And voila, my screen saver works as desired.
    However, this is not my intention: I only would like to set the timeouts to 0, since I like it to manually turn my display via DPMS off, e.g., with 'xset dpms force off' .

    Maybe someone could verify this behavior and knows where concretely to report this BUG such that it will be repaired?

    Thanks again,

    Chris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •