Results 1 to 3 of 3

Thread: Solved: /usr/lib/YaST2/plugin/libpy2lang_perl.so

  1. #1

    Thumbs up Solved: /usr/lib/YaST2/plugin/libpy2lang_perl.so

    Hi, I fixed this message today and want to share to solution for basic users:

    Code:
    Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so: libperl.so: cannot open shared object file: No such file or directory
    Just run the following command as user (or root):

    Code:
    wget http://download.opensuse.org/repositories/openSUSE:/11.2/standard/i586/yast2-perl-bindings-2.18.0-2.1.i586.rpm && sudo rpm -i --force yast2-perl-bindings* && rm yast2-perl-bindings* && sudo zypper dup

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Solved: /usr/lib/YaST2/plugin/libpy2lang_perl.so

    If you 'fixed' it, it means you have Factory or alternative Y2 location which messed up your existing installation, which "basic" users should never run into.

  3. #3

    Default Re: Solved: /usr/lib/YaST2/plugin/libpy2lang_perl.so

    True, just realized that a coupple of days ago -b.

    Anyways anybody with the same problem in the future can use my script (they just need to change the version numbers).
    PC: M3N78, AMD Athlon 64 X2 7750, 4GB DDR2 800MHz, Nvidia 9800GT 512M, HD 500GB SATA2
    OS: Arch i686/OpenSUSE 11.2 x86 (backup)/Windows 7 Ultimate 32-bit
    Other: MS Natural Ergonomics 4K, Logitech G5, 24M Internet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •