Hi, I fixed this message today and want to share to solution for basic users:

Code:
Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so: libperl.so: cannot open shared object file: No such file or directory
Just run the following command as user (or root):

Code:
wget http://download.opensuse.org/repositories/openSUSE:/11.2/standard/i586/yast2-perl-bindings-2.18.0-2.1.i586.rpm && sudo rpm -i --force yast2-perl-bindings* && rm yast2-perl-bindings* && sudo zypper dup