In the 11.2 distro, why does the package postgresql-jdbc contain the 8.2 jdbc drivers while the other postgres-* packages are all 8.4?

And why does the postgres-jdbc package name show 8.1, but contains 8.2 drivers?

I know there is an easy fix: just download the 8.4 JDBC drivers from jdbc.postgresql.org, but would this not be a simple fix for the packagers?