Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: lost windows option from boot menu

  1. #1

    Default lost windows option from boot menu

    Hello,

    I'm new to linux and have just installed it on my pc. I already had windows installed on the c drive so linux suse 11.2 has been installed onto d. There was a problem after I finished the install - after I rebooted no menu appeared, the pc just hung on a black screen with flashing cursor, so I put the linux DVD in again and rain a repair. It repaired the boot menu but now there is no option to boot into windows. I can see that windows is still installed but can someone please tell me how I can load my old windows. Thanks and apologies if this has been asked already.

  2. #2

    Default Re: lost windows option from boot menu

    I have taken a look at the boot manager GRUB that I found through YAST and tried to add windows xp but its still not working. Please can someone help.

  3. #3

    Default Re: lost windows option from boot menu

    Get to a terminal in SUSE, then run

    Code:
    su
    fdisk -l
    cat /boot/grub/menu.lst
    Paste the output here.

  4. #4

    Default Re: lost windows option from boot menu

    Disk /dev/sda: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xe70ae70a

    Device Boot Start End Blocks Id System
    /dev/sda1 1 4865 39078081 7 HPFS/NTFS
    /dev/sda2 * 4866 9729 39070080 f W95 Ext'd (LBA)
    /dev/sda5 4866 7821 23736037 7 HPFS/NTFS
    /dev/sda6 7821 7904 674698+ 82 Linux swap / Solaris
    /dev/sda7 7905 8659 6064506 83 Linux
    /dev/sda8 8660 9729 8594743+ 83 Linux
    linux-535o:/home/rdm # cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Fri Dec 4 21:29:47 ICT 2009
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,6)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title SUSE LINUX
    root (hd0,6)
    kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD800AAJS-00PSA0_WD-WMAP99767270-part7 repair=1 resume=/dev/disk/by-id/ata-WDC_WD800AAJS-00PSA0_WD-WMAP99767270-part6 splash=silent quiet showopts vga=0x31a
    initrd /boot/initrd

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- SUSE LINUX
    root (hd0,6)
    kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD800AAJS-00PSA0_WD-WMAP99767270-part7 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
    initrd /boot/initrd

    ###Don't change this comment - YaST2 identifier: Original name: menu###
    title Windows XP1
    root (hd0,4)
    configfile Windows XP

    ###Don't change this comment - YaST2 identifier: Original name: menu###
    title windows xp2
    root (hd0,7)
    configfile windows xp2

    ###Don't change this comment - YaST2 identifier: Original name: menu###
    title windows xp3
    root (hd0,0)
    configfile windows xp3
    linux-535o:/home/rdm #

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,832
    Blog Entries
    20

    Default Re: lost windows option from boot menu

    Remove those 3 windows entries and replace this:

    Code:
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Windows
    rootnoverify (hd0,0)
    chainloader (hd0,0)+1
    You can edit the file with:

    Code:
    kdesu kwrite /boot/grub/menu.lst
    or in gnome
    Code:
    gnomesu gedit /boot/grub/menu.lst
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: lost windows option from boot menu

    scuse igorance but I am attempting to do as you say using a terminal window and I get this response:

    linux-535o:/home/rdm # kdesu kwrite /boot/grub/msnu.lst
    kdeinit4: preparing to launch /usr/lib/libkdeinit4_klauncher.so
    kdeinit4: Communication error with launcher. Exiting!
    KCrash: Application 'kwrite' crashing...
    sock_file=/root/.kde4/socket-linux-535o/kdeinit4__0
    Warning: connect() failed: : Connection refused
    KCrash cannot reach kdeinit, launching directly.
    linux-535o:/home/rdm #

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,832
    Blog Entries
    20

    Default Re: lost windows option from boot menu

    Do it in a user terminal not a su one
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: lost windows option from boot menu

    Well its good windows is still there, its just not loading in GRUB.
    I have seen this a few times, its tricky to get it fixed but not impossible.
    If it gives you too much of a fuss you can try supergrubdisc, I think it can help with windows dual boots as well
    https://features.opensuse.org/308357

  9. #9

    Default Re: lost windows option from boot menu

    Many thanks+ - that did the trick.

    One thing I have noticed in Windows is the cmdagent.exe is using a lot of memory. I had this problem a few weeks ago and found out it was cos of the new AVG antivirus so I unistalled it. Now its come back and the only change I have made this time is the linux install. Any ideas ?

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,169

    Default Re: lost windows option from boot menu

    Linux makes no changes to Windows except the boot. This will not effect windows.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •