Results 1 to 9 of 9

Thread: Annoying shutdown beep in GDM

  1. #1

    Default Annoying shutdown beep in GDM

    Hello everyone!

    This problem is starting to make me insane, so I will ask here for help because I could not find anything that would help.

    I installed openSUSE 11.2 with GNOME 2.28 on my DELL Inspiron 1720 notebook. KDE is installed as a fallback desktop.
    When I use GDM as a display manager, my system gives a crazy beep when I try to shutdown or restart. There is actually NO ERROR, the system shutdowns fine and everything gets back up perfectly on reboot.

    I googled a lot about that issue and found several "solutions", but none did work. Here is what I have done so far:
    - Disable sounds and system sounds in GNOME
    - Deinstall PulseAudio
    - Set the volume for "PC Beep" to 0% in alsamixer
    - Removed and blacklisted the kernel modules for the case speaker (snd_pcsp and pcspkr), I double-checked: They are no longer loaded

    Because that all did not help, I switched display manager to KDM and guess what? The beep is gone. So it is an issue/feature of GDM. KDM works fine but I cannot shutdown from GNOME, I get logged off and then I need to shutdown from KDM. I know it should be this way and that's ok. I would like to get GDM back so I can normally shutdown the system WITHOUT the annoying beep, because it is so loud that half of my class falls from their chairs when it happens.

    Any suggestions what to do?

  2. #2

    Default Re: Annoying shutdown beep in GDM

    *bump*

    No one has an idea how to fix that?

  3. #3

    Default Re: Annoying shutdown beep in GDM

    If you have not resolved this yet then have a look at

    disable reboot/shutdown beep - LinuxQuestions.org

    It worked for me!

    Cheers

  4. #4

    Default Re: Annoying shutdown beep in GDM

    I instead chose this route to disable the annoying beep during shutdown and restart

    added "blacklist pcspkr" in /etc/modprobe.d/50-blacklist.conf causing the kernel to not load the speaker module. Reboot for the changes to take effect.

    If you opt to do this then you can undo the changes made to /etc/rc.d/halt as suggested in the previous post.

  5. #5

    Default Re: Annoying shutdown beep in GDM

    This did not resolve my problem. When I edit the /etc/rc.d/halt file, I still have a beep but my system refueses to reboot. Gets stuck after "No more services left in this runlevel".

    I already blacklisted the module you suggested. I moved it from blacklist.conf to the 50-blacklist.conf but the beep still remains.

    I think that it is more related to GDM and not the systemwide halt routine, because when using KDM it works fine and does not beep. If it would be in the halt routine, there would be a beep in KDM too right?

  6. #6
    Join Date
    Jul 2008
    Location
    Wisconsin, USA
    Posts
    187

    Default Re: Annoying shutdown beep in GDM

    Hi I have the same problem and went through roughly the same as what you did. Finally I was able to turn it off by setting PC Beep in alsamixer to MUTE. I did set it to 0 before but it still beep. To mute it you need to press 'M'.

    Hope it helps.
    openSUSE 11.3 GM + M$ Win Vista HP TX1316au AMD Athlon 64 X2 Mobile TK-55, nVidia GeForce Go 6150

    openSUSE 11.3 GM + M$ Win 7 HP dm-3 AMD Neo X2 L335, ATI Mobility Radeon HD 3200

  7. #7
    Join Date
    May 2009
    Location
    Austin, Texas
    Posts
    7

    Red face Re: Annoying shutdown beep in GDM

    Using Yast and kdm:

    Open Yast (Administrator Settings)

    You may go to System and select /etc/sysconfig Editor

    In the /etc/sysconfig Editor expand the System tree,
    then expand the Boot tree,

    Select the entry titled "HALT_SOUND" and set the value to "no."

    This does it for me and is in fact the default "no."
    Respectfully,


    LightMan

  8. #8
    Join Date
    Dec 2009
    Location
    Thailand
    Posts
    60

    Default Re: Annoying shutdown beep in GDM

    Still is beep, But used text mode not beep.

  9. #9
    Join Date
    Dec 2009
    Location
    Thailand
    Posts
    60

    Default Re: Annoying shutdown beep in GDM

    I changed BIOS battery. Beep is stop.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •