Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: gnome shutdown/restart under openSUSE 11.2

  1. #1

    Default gnome shutdown/restart under openSUSE 11.2

    Hello fellow lizards,

    I'm running openSUSE 11.2 Gnome Desktop Environment. Whenever I try to either shutdown or restart my machine as a "normal user", I've been logged off instead! When I try to re-login the screen (xorg) freezes. I don't know how to debug this problem. The problem could be related to hal or d-bus or policykit or X-org..... simply I don't know.

    N.B. I can shutdown and restart my machine only as "super-user" (root).

    Please help me.

  2. #2

    Default Re: gnome shutdown/restart under openSUSE 11.2

    after initiating shutdown/reboot operation, try to switch to console (i.e. ctrl+alt+f1) and shutdown/reboot process should start (for me it's only usable workaround).
    s.

  3. #3

    Default Re: gnome shutdown/restart under openSUSE 11.2

    Hi,

    With kde4.3 I can shutdown directly using kdm of course but in xfce, hitting the shutdown button it goes to the login screen and have to click the menu and select the shutdown to properly turnoff the machine.

    Try looking at the login screen if you see the menu button if there is in gdm and choose the shutdown and see if it will work for you.

  4. #4

    Default Re: gnome shutdown/restart under openSUSE 11.2

    About half the time Shutdown actually shuts down my laptop (gnome, 11.2, x86_64). The other half of the time it drops me at the login screen. The same is true for Restart. If I get stuck at the login screen, I usually press the power button on my laptop, which presents me with a shutdown menu that actually works.

  5. #5

    Default Re: gnome shutdown/restart under openSUSE 11.2

    Same problem for me as well JJMT ;however, all in all 11.2 has corrected some 11.1 quirks for me, one being banshee now plays mp3 music smoothly and my dinovo keyboard does not sporadically disconnect.

  6. #6

    Default Re: gnome shutdown/restart under openSUSE 11.2

    Also same problem here
    in kde it works flawlessly, but in gnome shutting down or restarting always take me back to the login screen.
    is there a bug filed for this?

    All in all it look to me as if gnome did'nt get as much love as KDE,(login sound does'nt work, login and logout excessively slow, no sound bar (or rather deprecated without alternative)....)

  7. #7
    johnix NNTP User

    Default Re: gnome shutdown/restart under openSUSE 11.2

    To me it seems that "shutdown -P" (which Gnome uses) have the behavior of halting without power off on OpenSuse.The effect on Gnome is the return to the login screen. The question is, where can the behavior of "shutdown -P" be changed to power off? "shutdown -h" does a power off though.

    A workaround may be to write a wrapper for the shutdown program which will do "shutdown -h" in case of "shutdown -P".

  8. #8

    Default Re: gnome shutdown/restart under openSUSE 11.2

    Quote Originally Posted by johnix View Post
    To me it seems that "shutdown -P" (which Gnome uses) have the behavior of halting without power off on OpenSuse.The effect on Gnome is the return to the login screen. The question is, where can the behavior of "shutdown -P" be changed to power off? "shutdown -h" does a power off though.

    A workaround may be to write a wrapper for the shutdown program which will do "shutdown -h" in case of "shutdown -P".
    In terminal as su you can do /sbin/halt

  9. #9

    Default Re: gnome shutdown/restart under openSUSE 11.2

    same problem here.

    i've found the bug as resolved here:

    https://bugzilla.novell.com/show_bug.cgi?id=531538

    but even i've tried to re-install the gnome-session package (2.28.0-3.5), the issue persists.

    any ideas?

  10. #10
    Join Date
    Aug 2008
    Location
    Chicago (south of Loop)
    Posts
    3

    Default Re: gnome shutdown/restart under openSUSE

    For a home system (don't use indiscriminately in corporate environment)...

    Here's a workaround that will allow you to shutdown with a single mouse-click.

    1) Yast --> Security and Users --> Sudo
    2) Highlight Rules for sudo (top left)
    3) Click the Add button toward the bottom left
    4) User, Group or User Alias --> select your login userid from drop down menu
    5) Host or Host Alias --> ALL
    6) RunAs or RunAs Alias --> root
    7) Click the Add button at the bottom left
    8) Command: /sbin/init
    9) Click OK

    Along the bottom of the gnome desktop there's a panel.

    10) Right-click on the panel
    11) From the drop-up menu select "Add to panel"
    12) At the very top of the Add to Panel dialogue box select "Custom Application Launcher"
    13) Click the Add button toward the bottom right corner
    14) Type: Select --> Application in Terminal from that drop-down menu
    15) Name: Type in the command Shutdown
    16) Command: sudo /sbin/init 0
    17) If you wish to you can select any icon you wish by clicking on the flag to the left of the Launcher Properties dialogue box.

    When you click the Close button, the icon will appear on your panel.
    When you hover the mouse-pointer over the icon the word "Shutdown" will appear
    When you left-click on the icon the system will halt.


    To perform the same workaround with the restart command
    in step #15 Type in the command Restart
    in step #16 substitute this Command: sudo /sbin/init 6
    :
    .
    I sweat,... I smile,... I laugh,... I nurture,... I know.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •