Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: System freezes after update to 11.2

  1. #11

    Default Re: System freezes after update to 11.2

    It was 3-4 hours. It finished 4 passes and was 70% through the fifth one when I shut it down.

    So far - I installed with default settings - it fails
    I installed with ext3 instead of ext4 - it failed
    I tried Ubuntu 9.04, with ext3, which seemed to work
    & done an upgrade from Ubuntu 9.04 to 9.10 (keeping ext3)- which also failed.

    the machine is a 2.53Ghz processor with an 80G HDD and 500MB of RAM, maybe I'm just asking too much of it.

  2. #12

    Default Re: System freezes after update to 11.2

    I've been seeing something similar with a clean install of 11.2. What I've done to work around the issue is immediately after booting, I check to see if a particular process is running (I think it's startup_preload, but I'm not at my 11.2 computer to check). If I recall correctly, it's supposed to exit memory after the system boots, but about 75% of the time, it doesn't. Instead, it sits there eating all of my memory. If I kill it, the system remains stable for the rest of the session.

    Dunno if it's the same thing you're seeing, but I do know if I don't kill that process, my system becomes completely unusable.

  3. #13

    Default Re: System freezes after update to 11.2

    I found a "prepare_preload" on a VM I just installed. It was using 95% of the CPU after bootup, which would kill almost anything. I'll reboot my desktop & try again.

    thanks

  4. #14

    Default Re: System freezes after update to 11.2

    Quote Originally Posted by n_hand View Post
    I found a "prepare_preload" on a VM I just installed. It was using 95% of the CPU after bootup, which would kill almost anything. I'll reboot my desktop & try again.

    thanks
    That's what it's called. I knew it had the word "preload" in it, but I wasn't sure about the first word.

    Anyone else seeing similar behavior?

  5. #15

    Default Re: System freezes after update to 11.2

    I re-installed the system

    as soon as the system logged me in, I checked the monitor for anything hogging the CPU or memory. Nothing. A minute or so later, the updater found some updates that needed to be applied to the system. Prepare_preload kicked in. It ran for a couple of minutes, as needed by the updater, occasionally spiking to 90%, then shut itself off.

    I re-booted the system... it's currently sitting, waiting to "shutdown (localfs) network interfaces: eth0 name: BCM4401 100Base-T". translation - it's hosed (again)

  6. #16

    Unhappy Re: System freezes after update to 11.2

    Any word on this yet? I've seen in a couple places that there were some bugfixes for an inaccurate "PIDs got reused" error, but to this day, with all 11.2 patches applied, prepare_preload eats my RAM and CPU a few minutes after boot and doesn't quit. I have to kill it manually every time.

    On top of that, I've noticed that udev generates an incredible number of forks. Dunno if it's related.

  7. #17
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,857
    Blog Entries
    14

    Default Re: System freezes after update to 11.2

    If you're sure it's this, uninstall 'preload' and 'preload-kmp-YOURKERNELFLAVOR'. This will stop preload from being called.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #18

    Default Re: System freezes after update to 11.2

    That did the trick, but why? I like the concept of what preload does, and wish it worked properly on my computer.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •