I am afraid I have reached roadblock and need help. I attempted to upgrade to 11.2 via zypper, had some problems (maybe network issue or something) so I figured I would attempt again later. I have a clone of my old hard drive made via dd if=, which I have used many times to restore the entire drive, so I restored back to 11.1. No problem everything worked as before EXCEPT:

I noticed I can't run Firefox and Evolution in GNOME. When I run firefox in a terminal I get:

Code:
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
Yes I tried to enable and it gave me a message relating to being unable to merge into the data base. Every other app accesses the net fine. Even Firefox via wine is OK. Maybe this had nothing to do with it? Could it be a network hardware issue?

I tried to run Firefox in a browser as root and I got this:

Code:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
I thought my dd restore would overlay EVERYTHING back to the original even /tmp files, it has always worked before.

I have reinstalled firefox several times, still the same issue. Here is my current setup:

Code:
rpm -qa | grep xul | sort
mozilla-xulrunner190-1.9.0.15-0.1.2
mozilla-xulrunner190-32bit-1.9.0.15-0.1.2
mozilla-xulrunner190-gnomevfs-1.9.0.15-0.1.2
mozilla-xulrunner190-gnomevfs-32bit-1.9.0.15-0.1.2
mozilla-xulrunner190-translations-1.9.0.15-0.1.2
mozilla-xulrunner190-translations-32bit-1.9.0.15-0.1.2
mozilla-xulrunner191-1.9.1.5-4.1
mozilla-xulrunner191-32bit-1.9.1.5-4.1
mozilla-xulrunner191-gnomevfs-1.9.1.5-4.1
mozilla-xulrunner191-gnomevfs-32bit-1.9.1.5-4.1
rpm -qa | grep -i firefox | sort
MozillaFirefox-3.5.5-2.3
MozillaFirefox-branding-upstream-3.5.5-2.3

xulrunner -v
Mozilla XULRunner 1.9.1.5 - 2009110300

rpm -qa | grep -i nss | sort
compat-openssl097g-32bit-0.9.7g-146.11.1
insserv-1.12.0-22.23
libnsssharedhelper0-1.0.4-1.5
libnsssharedhelper0-32bit-1.0.4-1.5
libopenssl0_9_8-0.9.8h-28.11.1
libopenssl0_9_8-32bit-0.9.8h-28.11.1
libopenssl-devel-0.9.8h-28.11.1
mozilla-nss-3.12.4-1.2
mozilla-nss-32bit-3.12.3.1-1.1.1
nss-mdns-0.10-39.11
nss-mdns-32bit-0.10-39.6
openssh-5.1p1-40.15
openssh-askpass-5.1p1-40.15
openssl-0.9.8h-28.11.1
openssl-certs-0.9.8h-25.2.13
And from aplication.ini:

Code:
[App]
Vendor=Mozilla
Name=Firefox
Version=3.5.5
BuildID=2009110300
Copyright=Copyright (c) 1998 - 2009 mozilla.org
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}

[Gecko]
MinVersion=1.9.1.5
MaxVersion=1.9.1.5

[XRE]
EnableProfileMigrator=1
EnableExtensionManager=1

[Crash Reporter]
ServerURL=https://crash-reports.mozilla.com/submit
I am anxious to learn if anyone can help. I really need to get my e-mail back from evolution and would like to recover my passwords from Firefox. Help!

Thanks so much to all.