Results 1 to 5 of 5

Thread: Mount Windows Drive in Write Mode

  1. #1
    pbcal NNTP User

    Question Mount Windows Drive in Write Mode

    Hi, I am a new player in this Linux world. This is also my first post. So please excuse my ignorance.

    I have install 11.2 version with dual boot option with WinXp. During installation I selected to mount the windows drive in /windows/C folder. Now the mounted drive in read only if I login as a regular used. from command prompt I can login as root and write on the drive. What needs to be changed to make the drive writable for regular used. I could not find that option in the /etc/fstab file.

    I would appreciate any help on this and thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Belgrade, Serbia

    Default Re: Mount Windows Drive in Write Mode

    I do not know which editor you have, I will use "mcedit" for the example (you can install "mc" from YaST).

    open terminal, and type:
    #sudo mcedit /etc/fstab

    find a line where your windows partition is mounted (you will see the line where near end, it is writen "ntfs-3g").

    After "ntfs-3g" you will have bunch of parameters, and at the end you will have " 0 0"
    Change bunch of parameters to "default", so your line, after "ntfs-3g" looks like "default 0 0"

    Save it and reboot. You will now have write access.
    Emil Beli
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  3. #3

    Default Re: Mount Windows Drive in Write Mode

    Isn't it 'defaults'?

    [Welcome, by the way!]

  4. #4

    Default Re: Mount Windows Drive in Write Mode

    Your fstab should look like the below. If it does not, then update and reboot.

    You can reach fstab like this -- go to Yast2 -- open Partitioner -- dual click on NTFS partition -- click on Edit -- click on fstab options at the bottom (your "mount partition" should be checked).

    fstab options for ntfs in partitioner:

  5. #5
    pbcal NNTP User

    Default Re: Mount Windows Drive in Write Mode

    I tried the Yast2 way and it worked like a charm. Thanks for the great help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts