Results 1 to 9 of 9

Thread: nautilus won't automount usb disk

  1. #1
    Join Date
    Jun 2008
    Location
    Schenectady, NY
    Posts
    138

    Default nautilus won't automount usb disk

    I have an external USB disk that I use for backups. The filesystem is ext3. When I plug in the disk, it no longer automounts under 11.2, it was fine under 11.1.

    Here's the dmesg output when I plug the external drive in.

    Code:
    [799010.437032] usb 2-2: new high speed USB device using ehci_hcd and address 11
    [799010.552110] usb 2-2: New USB device found, idVendor=0d49, idProduct=7310
    [799010.552126] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [799010.552135] usb 2-2: Product: OneTouch        
    [799010.552142] usb 2-2: Manufacturer: Maxtor  
    [799010.552154] usb 2-2: SerialNumber: 2HA44955    
    [799010.552288] usb 2-2: configuration #1 chosen from 1 choice
    [799010.552497] scsi19 : SCSI emulation for USB Mass Storage devices
    [799010.552649] usb-storage: device found at 11
    [799010.552651] usb-storage: waiting for device to settle before scanning
    [799011.552655] scsi 19:0:0:0: Direct-Access     Maxtor   OneTouch         0125 PQ: 0 ANSI: 4
    [799011.553071] sd 19:0:0:0: Attached scsi generic sg5 type 0
    [799011.553637] sd 19:0:0:0: [sde] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
    [799011.554258] sd 19:0:0:0: [sde] Write Protect is off
    [799011.554265] sd 19:0:0:0: [sde] Mode Sense: 2d 08 00 00
    [799011.554267] sd 19:0:0:0: [sde] Assuming drive cache: write through
    [799011.555671] usb-storage: device scan complete
    [799011.555985] sd 19:0:0:0: [sde] Assuming drive cache: write through
    [799011.555996]  sde: sde1
    [799011.622872] sd 19:0:0:0: [sde] Assuming drive cache: write through
    [799011.622881] sd 19:0:0:0: [sde] Attached SCSI disk
    My USB flash drive (2GB, fat32) does automatically mount when I insert it, so I think it may be related to the filesystem on the drive. Here's the output from the thumb drive (odd how it sees it as a cdrom, must be the sandisk autorun garbage)./

    Code:
    [798793.041838] usb 1-2.2: New USB device found, idVendor=0781, idProduct=5406
    [798793.041851] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [798793.041861] usb 1-2.2: Product: U3 Cruzer Micro
    [798793.041868] usb 1-2.2: Manufacturer: SanDisk
    [798793.041875] usb 1-2.2: SerialNumber: 194261116281446E
    [798793.042045] usb 1-2.2: configuration #1 chosen from 1 choice
    [798793.042272] scsi18 : SCSI emulation for USB Mass Storage devices
    [798793.042413] usb-storage: device found at 7
    [798793.042414] usb-storage: waiting for device to settle before scanning
    [798794.042632] scsi 18:0:0:0: Direct-Access     SanDisk  Cruzer           8.01 PQ: 0 ANSI: 0 CCS
    [798794.043207] sd 18:0:0:0: Attached scsi generic sg5 type 0
    [798794.043996] sd 18:0:0:0: [sde] 3907711 512-byte logical blocks: (2.00 GB/1.86 GiB)
    [798794.044366] scsi 18:0:0:1: CD-ROM            SanDisk  Cruzer           8.01 PQ: 0 ANSI: 0
    [798794.045618] sd 18:0:0:0: [sde] Write Protect is off
    [798794.045632] sd 18:0:0:0: [sde] Mode Sense: 45 00 00 08
    [798794.045635] sd 18:0:0:0: [sde] Assuming drive cache: write through
    [798794.048742] sr1: scsi3-mmc drive: 48x/48x tray
    [798794.048911] sr 18:0:0:1: Attached scsi CD-ROM sr1
    [798794.049027] sr 18:0:0:1: Attached scsi generic sg6 type 5
    [798794.049611] sd 18:0:0:0: [sde] Assuming drive cache: write through
    [798794.049635]  sde: sde1
    [798794.051001] usb-storage: device scan complete
    [798794.051863] sd 18:0:0:0: [sde] Assuming drive cache: write through
    [798794.051878] sd 18:0:0:0: [sde] Attached SCSI removable disk
    [798794.587922] ISO 9660 Extensions: Microsoft Joliet Level 3
    [798794.598401] ISOFS: changing to secondary root
    [798818.537392] usb 1-2.2: USB disconnect, address 7
    A 3rd external usb hard drive, also formatted fat32 mounts automatically.

    What has changed between 11.1 and 11.2 so that now the filesystem on the external drive matters?

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: nautilus won't automount usb disk

    Is this KDE4? If so, AFAIK the device notifier in it still don't have the option to automount a device, you have to click on the device in it's list to open another window that give you a few choices (open with some app, mount, do nothing). Is that what you are referring about?

    Your dmesg output doesn't show anything wrong that I can see, I suppose if you try to mount the drive manually it will.

    KDE 3 gave you the option to automount.

    OTOH there are some automount packages for gnome, search webpin for 'automount', you could check if they are installed.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: nautilus won't automount usb disk

    Oops. just noticed 'nautilus' in the thread title, and that means gnome... Sorry for the kde comments.

  4. #4
    Join Date
    Jun 2008
    Location
    Schenectady, NY
    Posts
    138

    Default Re: nautilus won't automount usb disk

    Quote Originally Posted by brunomcl View Post
    Oops. just noticed 'nautilus' in the thread title, and that means gnome... Sorry for the kde comments.
    No problem, I appreciate the reply. The funny thing is it works for fat32 formatted drives and not ext3. I'm able to manually mount the ext3 drive using gnome-mount as a regular user, but then I can't unmount it unless I become root.

  5. #5

    Default Re: nautilus won't automount usb disk

    Hello All,

    This sounds like hal nightmare stuff ...

    Since the release of 11.0, I have had issues with drives belonging to raid volumes and such showing up in nautilus places, etc.

    The settings for how nautilus interacts with dbus/whatever are under /usr/share/hal/fdi/policy ....


    I suspect that the filesystem on your usb device is not clean. Figure out the name of the device (e.g. /dev/sda2). The easiest way is to run "yast2 disk" as root. The run "fsck /dev/<id_your_find_from_yast>".

    Good luck!

  6. #6
    Join Date
    Jun 2008
    Location
    Schenectady, NY
    Posts
    138

    Default Re: nautilus won't automount usb disk

    Quote Originally Posted by oxala View Post
    Hello All,

    This sounds like hal nightmare stuff ...

    Since the release of 11.0, I have had issues with drives belonging to raid volumes and such showing up in nautilus places, etc.

    The settings for how nautilus interacts with dbus/whatever are under /usr/share/hal/fdi/policy ....
    Thanks, I'll check that out when I get home tomorrow and see if I can find something there.


    I suspect that the filesystem on your usb device is not clean. Figure out the name of the device (e.g. /dev/sda2). The easiest way is to run "yast2 disk" as root. The run "fsck /dev/<id_your_find_from_yast>".

    Good luck!
    I actually did this before posting, because I saw something in the dmesg output about it being mounted too many tmies without a check. It took nearly an hour, but it was clean.

  7. #7
    Salmir82 NNTP User

    Smile Re: nautilus won't automount usb disk

    Hi, i am new in this forum, i had problem to mount usb with gnome, but my problem was with gnome-mount.

    Maybe you could solve like me.

    look at this lowlevelgnome-mount (hal) automount usb owned root

  8. #8
    Salmir82 NNTP User

    Smile Re: nautilus won't automount usb disk

    I re-install gnome-mount, reset the notebook and when i started the usb was working well.

    I hope you could solve in this way too.

  9. #9
    Join Date
    Jun 2008
    Location
    Schenectady, NY
    Posts
    138

    Default Re: nautilus won't automount usb disk

    Quote Originally Posted by Salmir82 View Post
    Hi, i am new in this forum, i had problem to mount usb with gnome, but my problem was with gnome-mount.

    Maybe you could solve like me.

    look at this lowlevel**gnome-mount (hal) automount usb owned root
    Thanks, this didn't work for my disk. As a troubleshooting step, I reformatted one of my pen drives with ext3 and gnome had no problems mounting it. Now the only difference between disks that mount and the one that doesn't is the one that isn't working is using a GPT partition table.

    This worked in 11.1.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •