Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Eclipse Confirm Buttons not working in OpenSuse 11.2?

  1. #1

    Default Eclipse Confirm Buttons not working in OpenSuse 11.2?

    Hi all,

    yesterday installed a fresh OpenSuse 11.2. Since then the confirm buttons (OK / YES / ...) are not working, when clicking (mouse). An keyboard ENTER-press does work.

    What is the problem? Is it an OpenSuse bug?

    Help will be appreciated.

    Remco

  2. #2

    Post Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    I have not experienced that issue myself, having just upgraded from 11.1 to 11.2 and using Eclipse Galileo.

    Usually when I have such silly things with Eclipse, I'll just re-install it, or install another copy into another directory. That usually clear it up.

    Cheers,
    LewsTherin

  3. #3

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    That's what I also did, but it did not work. I am also using Galileo (Eclipse 3.5).

    When I hit File -> New Project -> Java Project, I can't press Next. This is at various places everywhere in Eclipse (for example font settings etc.).

    I am using KDE4.3...

    Did not try on other Java apps yet.

  4. #4

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    starting Eclipse with the following command fixed it for me:
    > GDK_NATIVE_WINDOWS=true eclipse

  5. #5
    vedantaulises NNTP User

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    It works for me, Thanks gabrielalexm

  6. #6

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    Worked for me as well. Thank you!!

  7. #7
    Join Date
    Oct 2008
    Location
    Central Florida (United States)
    Posts
    44

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    Just to piggy back this thread:

    I can only find Eclipse 3.4 in the repo. Are you guys installing it directly into your ~/bin or what?

    I need to run eclipse PDT which is in galileo (eclipse 3.5) and have also been having the button issue. I have been holding the mouse over the button I need and hitting <enter>

    Incentively, I an having a similar issue with Firefox when it suggests web addresses via the address bar.

    I think it a tad clunky to have to run eclipse as root to import new plug-ins.

    If you guys have a better solution as well as an actual XHTML editor for eclipse I would appreciate it.

    While I am at it: throw in a jQuery editor as well.

  8. #8
    Join Date
    Jan 2010
    Posts
    2

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    Seems the repository eclipse is always a version behind for key functionality. After downloading galileo directly from the eclipse.org site, exporting GDK_NATIVE_WINDOWS=true fixed the issue for me. I switched to GNOME for 11.2 and it appears KDE and GNOME have the same issue. Switching to the sun jdk didn't make a difference either.

    This is an openSUSE 11.2 bug right?

  9. #9

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    No, it's not just OpenSuSE. Same problem in Ubuntu. It's an Eclipse bug (#291257).

    For more info see the thread called "Eclipse doesn't accept mouse clicks on buttons" in the "Pre-Release/Beta" forum.

  10. #10

    Default Re: Eclipse Confirm Buttons not working in OpenSuse 11.2?

    Thanks for the GDK_NATIVE_WINDOWS=true hint. I would have never guessed. I experienced the same problems described in the first post, and setting the variable fixed it.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •