Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 11.2, KDE and GTK

  1. #1

    Default 11.2, KDE and GTK

    Sorry to raise that question again. Let us just make clear if it's a bug (feature?) in openSUSE 11.2

    To highlight the problem, I set View Background color to magenta and Window Text color to yellow in KDE. I do NOT want to apply colors to non-KDE4 applications.

    http://img21.imageshack.us/img21/590...pensuse111.jpg shows normal behaviour, as in openSUS 11.1, but also in Ubuntu (Jaunty and Karmic) and Fedora.

    http://img685.imageshack.us/img685/6...pensuse112.jpg shows OpenSUSE 11.2 behaviour.

    Gqview is just one among many GTK applications. It does affect all the others (i.e. Firefox, etc). I haven't found a way to prevent KDE to put its colors on GTK apps.

  2. #2
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    243

    Default Re: 11.2, KDE and GTK

    Quote Originally Posted by please_try_again View Post
    I haven't found a way to prevent KDE to put its colors on GTK apps.
    Not sure, but you can try:
    System Settings -> Look & feel -> Appearance -> Color
    select the "Options" tab, and uncheck the "Apply colors to non-KDE applications".
    The dark side of the American Dream of few may enjoy is that it is often built upon the nightmare many have to live with.

  3. #3

    Default Re: 11.2, KDE and GTK

    It is unchecked. The problem is that KDE on 11.2 doesn't take this setting into account.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: 11.2, KDE and GTK

    Not even after logging out and back in?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: 11.2, KDE and GTK

    Quote Originally Posted by Knurpht View Post
    Not even after logging out and back in?
    Not after logging out and back, as root or normal user, no matter how I start kde (startx, gdm, xdm), whether I changed KDE colors or not and with any Gtk theme I choose. Even not after deleting ~/.kde4 and restarting a "nacked" KDE. The Gtk theme itself is applied in both cases (as you can see on the pictures I linked to). Just the colors are overwritten by KDE. I should add that the Gtk theme and colors are working as expected in any other case (Gnome or other WMs on that machine) and KDE under openSUSE 11.1 as well. The ~/.gtkrc-2.0-kde4 (generated by KDE while setting up colors and themes) looks a little bit weird, since it includes a system file after a user file, and the contrary would be more logical:

    Code:
    # This file was written by KDE
    # You can edit it in the KDE control center, under "GTK Styles and Fonts"
    
    include "/usr/local/share/themes/niglo-openSUSE/gtk-2.0/gtkrc"
    include "/etc/gtk-2.0/gtkrc"
    
    style "user-font"
    {
            font_name="Sans Serif"
    }
    widget_class "*" style "user-font"
    
    gtk-theme-name="niglo-openSUSE"
    gtk-font-name="Sans Serif 9"
    But editing that file didn't change anything. And the choosen theme is applied anyway. So I guess this file is not the problem.

  6. #6
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    243

    Default Re: 11.2, KDE and GTK

    (Side note that probably won't help, but...)

    You upgraded from openSUSE 11.1 to 11.2, right ?

    Do you have ~/.kde4/Autostart/gnome-settings-daemon (which is a link to /usr/lib/gnome-settings-daemon/gnome-settings-daemon ) ?

    This was a trick under previous version of openSUSE to load the GTK settings when starting a KDE session.
    While I tried to find some more hints to help you, I discovered that this trick does not work anymore on 11.2. You can remove that link from ~/.kde4/Autostart/ if you still have it.
    (Run gnome-settings-daemon from console to see why it fails.)
    The dark side of the American Dream of few may enjoy is that it is often built upon the nightmare many have to live with.

  7. #7

    Default Re: 11.2, KDE and GTK

    You upgraded from openSUSE 11.1 to 11.2, right ?
    Not quite. I did a new install of 11.2 on one machine and still have 11.1 running on some others.
    Uninstalling qtcurve-kde4 and qtcurve-gtk2 did fix that problem. (!)
    However I will check if the gnome-settings-daemon is running in KDE and try to find out what it does.

    Thanks.

  8. #8

    Default Re: 11.2, KDE and GTK

    I personally like dark themes,but using dark themes make openoffice very ugly. It won't even show the real colors i am using. If i open a presentation file, it will show the background dark regardless of color used in presentation. So i want to use some other color themes in gtk apps just for the sake of openoffice. But in opensuse 11.2, even if i use other themes in gtk, it won't let me use those themes. What should i do,, removing qtcurve gtk and kde did not help at all.

    or any suggestions for just using light colors in openoffice.. manually changing the colors in kde won't show the original colors of the document.

  9. #9

    Default Re: 11.2, KDE and GTK

    BTW, what is the difference between qtcurve-kde4 and qtcurve-gtk2?

  10. #10

    Default Re: 11.2, KDE and GTK

    Quote Originally Posted by wildnux View Post
    BTW, what is the difference between qtcurve-kde4 and qtcurve-gtk2?
    one is for GTK the other for KDE4/QT4.
    Anyhow I think this is a bug, but also openSUSE does not use gtk-qt but instead uses its own variant.
    https://features.opensuse.org/308357

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •