Results 1 to 9 of 9

Thread: File manager - super user mode do not open files.

  1. #1
    Join Date
    Nov 2009
    Location
    Iran
    Posts
    32

    Default File manager - super user mode do not open files.

    Hi,

    I'm on a fresh openSUSE 11.2 with KDE
    I cannot open any file in super user mode of Dophin.

    I open Dolphin super user mode from
    Application launcher >>> Applications >>> System >>> File manager
    It opens the folders and links, for files accociated with Kwrite I got an error:
    KDEInint could not launch 'usr/bin/kwrite'.
    for the other files it just doesn't do anything at all

    I open it with
    kdesu dolphin
    it only can opens folders. for files (and links) I get
    KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
    The name org.kde.klauncher was not provided by any .service files

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: File manager - super user mode do not open files.

    Do it this way in a terminal

    kdesu kwrite /path_to/file

    eg: kdesu kwrite /etc/fstab
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2009
    Location
    Iran
    Posts
    32

    Default Re: File manager - super user mode do not open files.

    Quote Originally Posted by caf4926 View Post
    Do it this way in a terminal

    kdesu kwrite /path_to/file

    eg: kdesu kwrite /etc/fstab
    That does the job Thanks for the help.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: File manager - super user mode do not open files.

    Quote Originally Posted by samadg View Post
    That does the job Thanks for the help.
    Great. Well done
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: File manager - super user mode do not open files.

    That is just a workaround, how can it really be fixed? If I have dolphin opened in kdesu, I want to be able to open files. Not open a terminal and do another kdesu. In kde 4.3.4 this is still not solved?

  6. #6
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    275

    Default Re: File manager - super user mode do not open files.

    +100 here. Any solution, not a workaround?

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: File manager - super user mode do not open files.

    Quote Originally Posted by tpe View Post
    +100 here. Any solution, not a workaround?
    A workaround is a solution

    A Fix is something else. Keep adding your comments to bugzilla.

    I have another solution you might be interested in.

    Create yourself an new menu entry and call it SU Kwrite, the command is is kdesu kwrite. Like this


    Now all you need to do is add it to the context menu for text files.

    Now when you want to edit a file need su, just right click - open with: your newly made entry!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    mrahmawy NNTP User

    Default Re: File manager - super user mode do not open files.

    simply u have to enable the access to the local machine
    using the command
    xhost local:
    then it will work fine

  9. #9

    Default Re: File manager - super user mode do not open files.

    Quote Originally Posted by mrahmawy View Post
    simply u have to enable the access to the local machine
    using the command
    xhost local:
    then it will work fine
    I'm not running anything remotely...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •