Results 1 to 6 of 6

Thread: kwin not working at startup

  1. #1

    Red face kwin not working at startup

    it used to start alright for 2 weeks, and now suddenly it has stopped enabling itself at startup
    i have to do 'resume compositing' manually from configure desktop

    What should i do?

  2. #2

    Default Re: kwin not working at startup

    I'm having the same problem. My Compositing works like a charm once it's enabled, but on startup it defaults to being off, so I need to go enable it manually.

    Running KDE 4.3.3 "Release '3'" and OpenSUSE11.2

  3. #3
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: kwin not working at startup

    Hi calanor,

    What version of openSUSE are you using?
    Did you change anything just before it stopped working properly?
    What display driver are you using?

    You could try checking the power profile settings, which can turn off desktop effects.


    Barry.
    Desktop: openSUSE 11.3 (x86) LXDE
    Laptop: Arch Linux (x86_64) GNOME 3

  4. #4

    Default Re: kwin not working at startup

    I'll answer these questions too

    openSUSE 11.2
    ATI fglrx Driver (Catalyst 9.11)
    It works properly once I turn it to Resume Compositing, on startup I get a notification from the KDE Window Manager saying that another program has disabled compositing, and that I can re-enable it by pressing Alt Shift F11.

    On startup I typically have Firefox, Pidgin, Deluge, and XChat open.

  5. #5

    Default Re: kwin not working at startup

    Bump. This is still occuring.

  6. #6
    palladium NNTP User

    Default Re: kwin not working at startup

    LostChild1 wrote:
    > Bump. This is still occuring.



    you wrote: "...on startup I get a notification from the KDE Window
    Manager saying that another program has disabled compositing ... On
    startup I typically have Firefox, Pidgin, Deluge, and XChat open."

    so, try: shutdown all programs before shutting down openSUSE then
    restart and i *guess* nothing will disable composting..

    if that is true, then leave only *one* of those four apps (Firefox,
    etc) open when you shut down, and the next start see if composting
    still starts, or not....do that until you find WHICH one is shutting
    off composting..

    then, search bugzilla list for that program and see if it is a known
    bug, if not: make a bug report......and, until it is fixed either:

    - turn that application off before shutting down, or

    - enable composting each time you start up..

    --
    palladium

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •