Results 1 to 10 of 10

Thread: YAWP on 11.2 x86_64

  1. #1
    uwausac NNTP User

    Unhappy YAWP on 11.2 x86_64

    Hi, I'm quite new with Linux and maybe I ask some stupid questions. I wanny install the KDE-plasmoid YAWP. Therefore I included several KDE repositories. When I choose YAWP for installation, I get the messages (sorry it's German):

    plasmoid-yawp-0.2.3-5.4.x86_64 benötigt kdebase4-runtime >= 4.3.3, was aber nicht angeboten werden kann
    Nicht installierbare Anbieter: kdebase4-runtime-4.3.3-2.2.x86_64[KDE4.3_Core_Packages]
    kdebase4-runtime-4.3.3-2.2.i586[KDE4.3_Core_Packages]
    kdebase4-runtime-4.3.3-152.6.i586[KDE4.3_Factory_Core]
    kdebase4-runtime-4.3.3-152.6.x86_64[KDE4.3_Factory_Core]
    [ ] plasmoid-yawp auflösen durch das Ignorieren einiger Abhängigkeiten

    [ ] plasmoid-yawp-0.2.3-5.4.x86_64 nicht installieren

    [ ] Folgende Aktionen werden ausgeführt:
    kde4-filesystem-4.3.3-78.2.x86_64 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
    kdebase4-runtime-4.3.3-152.6.x86_64 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
    kdelibs4-4.3.3-3.1.x86_64 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
    ...
    What does it mean? What is an "Anbieterwechsel" (like "Change of vendor/supplier")? If I choose "plasmoid-yawp auflösen durch das Ignorieren einiger Abhängigkeiten" like "ignore dependencies", I get the message from the plasmoid "Angeforderte Komponente ist nicht auffindbar: yaWP". (like "component yaWP can't be found").

    If I choose the answer with all these "Anbieterwechesel" I get a new question with even more "Anbieterwechesel" and when I continue this way, other plasmoids, that worked before, don't work anymore. So I installed 11.2 from the begining to get the other plasmoid running again. A few weeks ago I played with 11.2RC1 on the same x64 machine. At this time I was somehow able to install YAWP without much problems, as far as I remember. What I am making wrong now?

  2. #2

    Default Re: YAWP on 11.2 x86_64

    The problem is that you included not the appropriate repositories?

    I recommend to you to keep the OSS, NON OSS, updates, packman (eventually nvidia or ati to that).

    The problem you encounter is because you have added a 4.3 community repo and no 4.3 repo but to be sure post the output of

    zypper lr -d
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3
    uwausac NNTP User

    Default Re: YAWP on 11.2 x86_64

    Thanks for you answer! Here's the output:
    zypper lr -d

    # | Alias | Name | Aktiviert | Aktualisieren | Priorität | Typ | URI | Dienst
    ---+-------------------------------------+--------------------------------------+-----------+---------------+-----------+--------+-----------------------------------------------------------------------------------------+-------
    1 | ATI_drivers | ATI drivers 11.1 | Ja | Ja | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
    2 | Emulators | Emulators | Ja | Ja | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_Factory |
    3 | KDE4.3_Community | KDE4.3 Community | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43 |
    4 | KDE4.3_Core_Packages | KDE4.3 Core Packages | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/43/openSUSE_11.2 |
    5 | KDE4.3_Factory_Community | KDE4.3 Factory Community | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_Factory |
    6 | KDE4.3_Factory_Core | KDE4.3 Factory Core | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_Factory |
    7 | KDE4.3_Playground | KDE4.3 Playground | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Playground/openSUSE_11.2_KDE_43 |
    8 | KDE4_Community | KDE4 Community | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
    9 | KDE4_Core_Packages_Stable | KDE4 Core Packages Stable | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2 |
    10 | KDE4_Playground | KDE4 Playground | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Playground/openSUSE_11.2 |
    11 | Mozilla | Mozilla | Ja | Ja | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    12 | OpenOffice | OpenOffice | Ja | Ja | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.2 |
    13 | VLC_Video_Lan_Client | VLC Video Lan Client | Ja | Ja | 99 | rpm-md | Index of /pub/vlc/SuSE/11.2/ |
    14 | WINE | WINE | Ja | Ja | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.2 |
    15 | http-download.opensuse.org-cb26e6db | Aktualisierungen für openSUSE 11.2-0 | Ja | Ja | 99 | rpm-md | Index of /update/11.2 |
    16 | openSUSE 11.2-0 | openSUSE 11.2-0 | Ja | Nein | 99 | yast2 | cd:/// |
    17 | repo-debug | openSUSE-11.2-Debug | Nein | Ja | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    18 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    19 | repo-oss | openSUSE-11.2-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    20 | repo-source | openSUSE-11.2-Source | Nein | Ja | 99 | NONE | Index of /source/distribution/11.2/repo/oss |

  4. #4

    Default Re: YAWP on 11.2 x86_64

    You need to decide which repo you need. You have both Factory and 4.3, factory will change to 4.4 svn in a matter of time. So either use the 4.3 repo and no factory or face the consequences of having such problems, if i were you i wouldn't use the 4.3 repo as you will not get any benefits from that as standard 4.3 will get the fixes from 4.3.3 backported anyway.

    Remove 5th, 6th 8th, 9th and 10th repo, install libdvdcss from vlc and delete that repo and afterwards add packman instead.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  5. #5

    Default Re: YAWP on 11.2 x86_64

    Oh, by the way, after you remove those repositories go to software management and update every package that shows up as red.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  6. #6
    uwausac NNTP User

    Default Re: YAWP on 11.2 x86_64

    Unfortunately I didn't succeed with your advices. zypper shows the following now:

    # | Alias | Name | Aktiviert | Aktualisieren | Priorität | Typ | URI | Dienst
    ---+-------------------------------------+--------------------------------------+-----------+---------------+-----------+--------+---------------------------------------------------------------------------------------+-------
    1 | ATI_drivers | ATI drivers 11.1 | Ja | Ja | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
    2 | Emulators | Emulators | Ja | Ja | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_Factory |
    3 | KDE4.3_Community | KDE4.3 Community | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43 |
    4 | KDE4.3_Core_Packages | KDE4.3 Core Packages | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/43/openSUSE_11.2 |
    5 | KDE4.3_Playground | KDE4.3 Playground | Ja | Ja | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Playground/openSUSE_11.2_KDE_43 |
    6 | Mozilla | Mozilla | Ja | Ja | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    7 | OpenOffice | OpenOffice | Ja | Ja | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.2 |
    8 | Packman_-_RWTH_Aachen | Packman - RWTH Aachen | Ja | Ja | 99 | rpm-md | Index of /packman/suse/11.2 |
    9 | WINE | WINE | Ja | Ja | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.2 |
    10 | http-download.opensuse.org-cb26e6db | Aktualisierungen für openSUSE 11.2-0 | Ja | Ja | 99 | rpm-md | Index of /update/11.2 |
    11 | openSUSE 11.2-0 | openSUSE 11.2-0 | Ja | Nein | 99 | yast2 | cd:/// |
    12 | repo-debug | openSUSE-11.2-Debug | Nein | Ja | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    13 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    14 | repo-oss | openSUSE-11.2-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    15 | repo-source | openSUSE-11.2-Source | Nein | Ja | 99 | NONE | Index of /source/distribution/11.2/repo/oss |


    but when I try to install YAWP I get still an error list (but it's a bit shorter now):

    #### YaST2 conflicts list - generated 2009-11-22 09:30:38 ####

    plasmoid-yawp-0.2.3-5.3.x86_64 benötigt kdebase4-runtime >= 4.3.3, was aber nicht angeboten werden kann
    Nicht installierbare Anbieter: kdebase4-runtime-4.3.3-2.2.x86_64[KDE4.3_Core_Packages]
    kdebase4-runtime-4.3.3-2.2.i586[KDE4.3_Core_Packages]
    [ ] Folgende Aktionen werden ausgeführt:
    kdebase4-runtime-4.3.3-2.2.x86_64 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
    oxygen-icon-theme-4.3.3-1.1.noarch installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
    oxygen-icon-theme-scalable-4.3.3-1.1.noarch installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
    [ ] plasmoid-yawp-0.2.3-5.3.x86_64 nicht installieren

    [ ] plasmoid-yawp auflösen durch das Ignorieren einiger Abhängigkeiten

    Ans after removing the repos there wasn't anything red in the software manager (or did I look at the wrong place?)

  7. #7
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,164

    Default Re: YAWP on 11.2 x86_64

    Did you do this
    After you removed the factory repos did you refresh Yast?
    Then after that in yast go to the Repository tab checking the Kde repos?
    Also you might want to remove that wine factory repo.
    I'm just a curious cat
    My 64 bit: RADEON RX 570 |CPU AMD - Ryzen 5 1600
    MOTHERBOARD B450M D53H GGABYTE
    Opensuse Tumbleweed Plasma 5

  8. #8

    Default Re: YAWP on 11.2 x86_64

    Ahhh, i can see where the problem lies, be default openSUSE doesn't change the vendor, you need to accept to install the 4.3.3 version kdebase-runtime, if you want to not see those messages anymore you need to correct the /etc/zypp/zypp.conf file and change it to allow vendor change.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  9. #9
    uwausac NNTP User

    Default Re: YAWP on 11.2 x86_64

    Thanks for your advises. Finally I solved the problem - but I'm sure that I will return soon with my next questions :-)
    Because of your help I found this 'Button' "Switch system packages to the version in this repository" (labeled in English even in a German YAST) and I used the Button for the repository "KDE4.3 Core Packages". After this YAST installed YAWP without any complains :-) but when I tried to start this plasmoid I still got the following error message :-(

    "Dieses Objekt kann aus folgendem Grund nicht erzeugt werden: Angeforderte Komponente ist nicht auffindbar: yaWP"
    (like "This object can't be generated because of the following reason: requested component can't be found: yaWP")

    I 'googled' for this message and found the command 'zypper -dup' and used it (also 'Wine' and 'Emulators' were removed from the above repository list before). Maybe this was a bit too keen, but the system is not productive and it is for learning about Linux only.

    After this I was recommended to use 'zypper ps' and this showed me, that several processes where using files that had been deleted. That sounded a little bit frightening to me. And yaWP still showed the above error message. But after a reboot now everything seems fine so far and yaWP suddenly works :-) Maybe a reboot would have helped already after the first step and before the zypper -dup.

  10. #10

    Default Re: YAWP on 11.2 x86_64

    Well to be honest, you ONLY need to reboot if you updated the kernel, if you updated the packages like KDE or GNOME then simple logout and login will suffice
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •