Results 1 to 3 of 3

Thread: Installing KDE3 on 11.1... why KDE4 dependencies?

  1. #1

    Question Installing KDE3 on 11.1... why KDE4 dependencies?

    Currently, I use XFCE4 and GNOME desktops. I want to try KDE3, but not KDE4 (which one is lighter? this old computer has limited resources). But when I selected 'KDE3 Desktop Environment' in Yast2 software manager, it auto-included a bunch of KDE4 programs. Why?

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,453

    Default Re: Installing KDE3 on 11.1... why KDE4 dependencies?

    Depends what you use; when it first came out KDE4 was reported as lighter than KDE3 but, as more applications that take advantage of the new facilities have been written, the situation appears to have been reversed for those who take advantage of the new facilities.

    Though KDE4 is built on a different version of Qt, it has common elements with KDE3. openSUSE has decided on this naming convention for the common elements because it puts them in a different location from those elements which are unique to KDE3.

  3. #3

    Default Re: Installing KDE3 on 11.1... why KDE4 dependencies?

    Thanks for the information! The installation went fine, and after a reboot, I'm enjoying KDE3.

    I used the Yast2 QT GUI to install the 'KDE3 Desktop Environment' pattern. This grabbed several packages from that category and 'KDE3 Base', but not absolutely everything in each category, such as Beagle related packages which I'd previously uninstalled. Very nice work! However, when I tested the same procedure on the commandline first:
    Code:
    me@computer #: su -
    root@computer #: zypper install --dry-run -t pattern kde3
    It included a lot more stuff, including things like Beagle. I wonder why the discrepancy.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •