Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: After openSUSE install, Windows won't sleep

  1. #1

    Default After openSUSE install, Windows won't sleep

    This is the strangest thing.

    When I install openSUSE and I boot back into Windows 7, Windows won't sleep. Meaning, when I put it to sleep, it immediately wakes up.

    I thought maybe it was a program I was running in Windows that was the problem. But after going through two installs of Windows 7 and openSUSE and troubleshooting, it seems that the problem begins only once I install openSUSE.

    Any ideas why this might be? I'm not sure what other info you might need (hardware is in the sig), but let me know and I'll supply it. This is a fresh install with Windows 7 and a fresh install of openSUSE. Windows goes to sleep fine after it's installed, drivers updated, AV and whatnot installed, but once openSUSE is installed Windows sleep breaks. So strange.

    Thanks for your help.
    Asus P5QL-E, Intel Core2Duo 8500 (3.1 Ghz), 4GB Team Elite PC6400 RAM, ATI HD4850, WD 500GB HD

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: After openSUSE install, Windows won't sleep

    Try a full shutdown, then boot W7 and try it.
    Does W7 have a pagefile like previous M$ releases, is it OK?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: After openSUSE install, Windows won't sleep

    After full shutdown, it still won't sleep.

    Not sure what a pagefile is. Sorry.
    Asus P5QL-E, Intel Core2Duo 8500 (3.1 Ghz), 4GB Team Elite PC6400 RAM, ATI HD4850, WD 500GB HD

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: After openSUSE install, Windows won't sleep

    Pagefile is Virtual Memory and is used to sleep a machine. Good luck finding it in W7. They made the file system idiot proof.
    Try Microsoft forums
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: After openSUSE install, Windows won't sleep

    pagefile.sys is a hidden system file, you have to find folder options in view menu of explorer to see it. I am not sure they write out that data to disk, when suspending to RAM, because it's instant unlike Hibernate where they save pages to a disk file.

    It's usually "Hibernate" aka Suspend to Disk, which would be disrupted, when Windows knows it doesn't have control of it's boot process, or hiberfil.sys gets deleted for some reason.

    Not sleeping aka Suspend to RAM is an odd one. I go from openSUSE to Vista & Win 7, and sleep always has worked for me, in the other OS (but not unfortunately now in 11.2, 11.1 it did work).

    I should poweroff the machine for 5 mins, then try booting cold into Windows. It could be that a Win driver fails to initialise things correctly, or relies on the BIOS doing it for you, and some optimisation has taken place.

  6. #6

    Default Re: After openSUSE install, Windows won't sleep

    My wife's laptop does this with Vista sometimes. It has no opensuse installed (her wireless card was not supported when we got it and now she's grown used to vista).

    I think it's a bios issue with her HP laptop.

  7. #7
    edca3 NNTP User

    Default Re: After openSUSE install, Win 7 won't sleep

    After reading about this issue, I tried to "sleep" in Win 7, and like other, Win 7 will go to see, then wake immediately. Prior to installing OpenSUSE 11.2, Win7's sleep worked flawlessly. Any ideas?

    I went into Ctrl panel/Sys and security/System /advanced system setting/ advanced /performance /advanced, and moved the virtual memory to the 2nd HD, which does not have a Linux partition. Didn't help.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: After openSUSE install, Windows won't sleep

    For anyone who is brave enough, I propose a test.

    Boot the W7 DVD and fix the Windows bootcode
    Now it should be as if there is no Linux installed.
    Does it work now?

    Actually, chances are your bootcode is intact and all you need to do is switch the boot flag back to the W7 install. See this:
    All About Grub - openSUSE

    But when you repair grub you will probably find it easier just to install grub on the MBR.

    It would be interesting to see the results
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    edca3 NNTP User

    Default Re: After openSUSE install, Windows won't sleep

    Quote Originally Posted by caf4926 View Post
    For anyone who is brave enough, I propose a test.

    Boot the W7 DVD and fix the Windows bootcode
    Now it should be as if there is no Linux installed.
    Does it work now?...
    Sorry, what do you mean? Reinstall Win7?

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: After openSUSE install, Windows won't sleep

    Quote Originally Posted by edca3 View Post
    Sorry, what do you mean? Reinstall Win7?
    No, just the boot code. When you boot the DVD you can fix what is commonly referred to as the MBR (Master Boot Record) - It's well known. W7 is a bit different than XP was. I have done it several times earlier in the year on test machine. I was breaking grub, re-installing it, breaking windows and so on, just for testing. It's easy. Just scary if you have never done it before.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •