Results 1 to 9 of 9

Thread: ATI HD4350: No GLX When Using fglrx

  1. #1
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default ATI HD4350: No GLX When Using fglrx

    I see a lot of people have been having problems with ATI driver installations, but I haven't seen any posts regarding this specific issue:

    When I install opensuse 11.2 x86_64 from the DVD, the provided radeonhd 1.3 driver works mostly fine. There are some occasional minor graphic aberrations, but nothing to cry over. Typing "glxinfo" in a console spews forth all kinds of GLX information, which all looks positive.

    When I try to install the Catalyst 9.10 or 9.11 drivers, the installation appears to be successful and X.org starts up fine, but my display is super slow. Moving windows around is painful. Typing "glxinfo" at the command line gives me an error message. My procedure basically involves running the ATI installer, choosing "automatic setup", and then running "aticonfig --initial" after installation is complete.

    I don't know if DRI is disabled, or if the GLX error is the culprit. I also read somewhere that there might be some conflict between the kernel's Radeon DRM module and the FGLRX driver.

    Can someone enlighten me please?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: ATI HD4350: No GLX When Using fglrx

    Two commands which may be useful:

    fglrxinfo (only applicable if using proprietary driver)

    glxinfo |grep direct

  3. #3
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default Re: ATI HD4350: No GLX When Using fglrx

    glxinfo gives me the following error message:

    Code:
    name of display: :0.0
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  136 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  19
      Current serial number in output stream:  19
    fglrxinfo gives me... exactly the same error.

    glxgears gives me... exactly the same error.

  4. #4

    Default Re: ATI HD4350: No GLX When Using fglrx

    Sluggish video could stem from a number of factors. First off, eliminate the 3D contribution. Configure Desktop -> Look & Feel -> Desktop -> General tab. Verify Enable Desktop Effects is unchecked. [You can always select this later.]

    Then, see if the fglrx module got loaded at all:
    Code:
    lsmod | grep -i fgl
    If it's not there, look at /etc/ati/fglrx-install.log. The last line should be "done.". If it isn't, you probably are missing some module build prerequisites; you have to install the kernel build packages.

    I am using the 9.10 ATI .run file in my AMD64 box with good performance (glxgears 6200fps) in openSuSE 11.2. I did not run sax2, and I did not need an xorg.conf file. I see some npviewer complaints in my syslog, but things are OK aside from that.

    HTH

  5. #5
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default Re: ATI HD4350: No GLX When Using fglrx

    Quote Originally Posted by tcubed_bus View Post
    Sluggish video could stem from a number of factors. First off, eliminate the 3D contribution. Configure Desktop -> Look & Feel -> Desktop -> General tab. Verify Enable Desktop Effects is unchecked. [You can always select this later.]
    Yep, already made sure of that.

    Quote Originally Posted by tcubed_bus View Post
    Then, see if the fglrx module got loaded at all:
    Code:
    lsmod | grep -i fgl
    Yep, it's loaded.

    Quote Originally Posted by tcubed_bus View Post
    I am using the 9.10 ATI .run file in my AMD64 box with good performance (glxgears 6200fps) in openSuSE 11.2. I did not run sax2, and I did not need an xorg.conf file. I see some npviewer complaints in my syslog, but things are OK aside from that.

    HTH
    I tried without an xorg.conf file, and video performance seems to have improved noticeably. It's almost as smooth as using the radeonhd driver. However, still no GLX.
    Frank Gore
    - '78 Trans Am, Pontiac 400... oops, wrong forum!
    - 2008 Kona Hoss, custom built from scratch... oops, wrong forum again!
    ...bah! Forget it! Who needs a sig anyways?

  6. #6

    Default Re: ATI HD4350: No GLX When Using fglrx

    Quote Originally Posted by puregore View Post
    .... still no GLX.
    A viable fglrx module loaded, and still no GLX? Hmmmm...

    More than one video driver module loaded?
    Code:
    lsmod | grep -i rad
    Garbage in the driver's database?
    Code:
    rm /etc/ati/amdpcsdb
    restart X
    Don't know what else to suggest for this puzzle.

  7. #7
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default Re: ATI HD4350: No GLX When Using fglrx

    Quote Originally Posted by tcubed_bus View Post
    A viable fglrx module loaded, and still no GLX? Hmmmm...

    More than one video driver module loaded?
    Code:
    lsmod | grep -i rad
    Nope, that came up blank. I sifted through the lsmod results manually, only one video driver loaded.

    Quote Originally Posted by tcubed_bus View Post
    Garbage in the driver's database?
    Code:
    rm /etc/ati/amdpcsdb
    restart X
    Did not change anything.

    Quote Originally Posted by tcubed_bus View Post
    Don't know what else to suggest for this puzzle.
    Frank Gore
    - '78 Trans Am, Pontiac 400... oops, wrong forum!
    - 2008 Kona Hoss, custom built from scratch... oops, wrong forum again!
    ...bah! Forget it! Who needs a sig anyways?

  8. #8

    Default Re: ATI HD4350: No GLX When Using fglrx

    One final thought: my /var/log/Xorg.0.log file tells a happy tale of successful fglrx and GLX actions. Maybe it can give you a clue as to where things go wrong.

  9. #9
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default Re: ATI HD4350: No GLX When Using fglrx

    problem solved. Somehow the ATI installer was only doing half the job, and the installed files were incomplete.

    The following thread:

    Generating catalyst 9.11 rpm's on openSUSE 11.2 - openSUSE Forums

    solved my problem. Now all works as intended.
    Frank Gore
    - '78 Trans Am, Pontiac 400... oops, wrong forum!
    - 2008 Kona Hoss, custom built from scratch... oops, wrong forum again!
    ...bah! Forget it! Who needs a sig anyways?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •