Results 1 to 4 of 4

Thread: Trouble starting Miro

  1. #1
    Kevin Miller NNTP User

    Default Trouble starting Miro

    I installed 11.2 the other day, and most things are running just fine.
    However I can't seem to get Miro to work.

    Initially, Miro was installed from the openSUSE repositories. It
    started just fine, but when I clicked on the download button to get a
    video it would act like it was starting the download but just sat there.
    It wasn't hung - I could still navigate around w/in Miro but nothing
    would come down.

    I thought maybe the version at Packman would work better, so I installed
    it. Now all I get is a bouncing Miro icon when it's trying to start up,
    but then it just quits. In ~/.miro/miro-log I have the following output:

    2009-11-17 22:01:44,147 INFO Starting up Miro
    2009-11-17 22:01:44,158 INFO Version: 2.5.3
    2009-11-17 22:01:44,169 INFO OS: Linux 2.6.31.5-0.1-default i686
    2009-11-17 22:01:44,171 INFO Revision:
    ssh://wguaraldi@pcf1.pculture.org/var/git/miro/ - 7137156b
    2009-11-17 22:01:44,172 INFO Builder: abuild@loft1070
    2009-11-17 22:01:44,173 INFO Build Time: 1258493655.65
    2009-11-17 22:01:44,174 INFO Starting event loop thread
    2009-11-17 22:01:44,177 INFO Restoring database...
    2009-11-17 22:01:44,179 INFO Python version: 2.6.2 (r262:71600,
    Oct 24 2009, 03:16:31)
    [GCC 4.4.1 [gcc-4_4-branch revision 150839]]
    2009-11-17 22:01:44,184 INFO Gtk+ version: (2, 18, 1)
    2009-11-17 22:01:44,185 INFO PyGObject version: (2, 20, 0)
    2009-11-17 22:01:44,185 INFO PyGtk version: (2, 16, 0)
    2009-11-17 22:01:44,186 INFO Language: [('LANG',
    'en_US.UTF-8')]
    2009-11-17 22:01:44,187 INFO Sqlite3 version: 3.6.16
    2009-11-17 22:01:44,192 INFO Pysqlite version: 2.4.1
    2009-11-17 22:01:44,191 INFO set_renderer: trying to add
    gstreamerrenderer


    Checking for running processes, I get the following (watch the line wrap):
    mkm@koala:~/.miro> ps aux | grep miro
    mkm 10508 0.0 0.1 4132 1324 ? S 22:57 0:00 /bin/sh
    /usr/bin/miro
    mkm 10509 9.1 2.9 105628 30152 ? Sl 22:57 0:00
    /usr/bin/python /usr/bin/miro.real
    mkm 10518 1.5 2.1 112472 22316 ? S 22:57 0:00
    /usr/bin/python /usr/bin/miro.real


    A couple days ago I followed the steps at:
    http://opensuse-community.org/Restricted_Formats/11.2
    to enable codecs & such that didn't come in the default install.

    My repos are this:
    # | Alias | Name |
    Enabled | Refresh
    --+-------------------------------------+-----------------------------+---------+--------
    1 | Nvidia | Nvidia |
    Yes | Yes
    2 | Packman Repository | Packman Repository |
    Yes | Yes
    3 | http-download.opensuse.org-b2b37260 | Updates for openSUSE 11.2-0 |
    Yes | Yes
    4 | openSUSE 11.2-0 | openSUSE 11.2-0 |
    Yes | No
    5 | repo-debug | openSUSE-11.2-Debug |
    No | Yes
    6 | repo-non-oss | openSUSE-11.2-Non-Oss |
    Yes | Yes
    7 | repo-oss | openSUSE-11.2-Oss |
    Yes | Yes
    8 | repo-source | openSUSE-11.2-Source |
    No | Yes

    Videolan repo was added, but I removed it.

    Any help would be appreciated...


    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  2. #2
    Join Date
    Dec 2008
    Location
    Germany
    Posts
    3

    Default Re: Trouble starting Miro

    Same problem here.
    I tried to find out if there's any version conflict with the Python stuff, but I cannot find any useful result. Maybe I'm not common enough with this kind of software. :-(

  3. #3
    Join Date
    Dec 2008
    Location
    Germany
    Posts
    3

    Default Re: Trouble starting Miro

    I just updated to miro-2.5.3-4.pm.4.18, and everything now seems to work fine for me.
    Hope this update will fix your probs, too.

  4. #4

    Default Re: Trouble starting Miro

    Quote Originally Posted by Cumulum View Post
    I just updated to miro-2.5.3-4.pm.4.18, and everything now seems to work fine for me.
    Hope this update will fix your probs, too.
    I still have the problem, with that version.

    FYI, there is an open bug: https://bugzilla.novell.com/show_bug.cgi?id=561312

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •