Mandriva 2009.1 has libdb 4.6 and 2010 is up to libdb 4.7. Does anyone know why Opensuse 11.2 is still on 4.5?

This version difference has caused a problem with my spamassassin databases, which have been finely tuned over a long period of time.