Results 1 to 6 of 6

Thread: gstreamer issue

  1. #1

    Default gstreamer issue

    Is anyone else having issues with reading movies with Totem/gstreamer ?

    It used to work well after the 11.2 install, but probably some updates or set up messed it up.

    Now, opening a movie with totem leave me with a blank screen.
    It appears to be unable to detect the codec to read it.

    I tested xine with mplayer and miro and it works very well.

    But when I try to use gstreamer with totem, gstreamer or banshee, the read does not start.

    I tried several things :
    - reinstalling all possible codecs
    - reinstalling all gstreamer packages, from opensuse and then from packman
    - compiling the lastest gstreamer sources

    And nothing improved.

    The movies are I guess encoded with xvid and mpeg-4.

    What else could be possibly wrong ?

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: gstreamer issue

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: gstreamer issue

    Thanks for the suggestion, but it is not what I am looking for.

    The workaround of using VLC does not satisfy me, I want to use Totem and gstreamer for their integration with Gnome.

    It has always worked for the years I have been using it, so there is no reason that I resign using it.

    If it is broken on openSUSE, I will submit a bug, but I want a confirmation that it is not only due to a wrong operation of mine.

    Anyway, it is supposed to work flawlessly.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: gstreamer issue

    I never said anything about VLC. I would say Smplayer or Gnome-Mplayer

    I would however suggest you pay careful attention to repo priority and where your multi-media packages are being supplied from. You'll notice the easy switcher at the top of software management now.

    Why not post your repo info for us:

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: gstreamer issue

    Yes, it works with everything using libxine, like gnome-mplayer. But I still want to use gstreamer.

    There it is.

    Code:
    % zypper lr -d
    #  | Alias                               | Nom                                 | Activ | Rafrachir | Priorit | Type   | URI                                                                                   | Service
    ---+-------------------------------------+-------------------------------------+--------+------------+----------+--------+---------------------------------------------------------------------------------------+--------
    1  | Chromium                            | Chromium                            | Oui    | Non        |  200     | rpm-md | http://download.opensuse.org/repositories/home:/dbuck/openSUSE_Factory/               |        
    2  | Fwzs                                | Fwzs                                | Oui    | Non        |   99     | rpm-md | http://download.opensuse.org/repositories/home:/lnussel:/fwzs/openSUSE_Factory        |        
    3  | GNOME:Community                     | GNOME:Community                     | Oui    | Oui        |   50     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Community/openSUSE_Factory/          |        
    4  | Packman                             | Packman                             | Oui    | Oui        |    1     | rpm-md | http://packman.mirrors.skynet.be/pub/packman/suse/11.2/                               |        
    5  | X11:windowmanagers                  | X11:windowmanagers                  | Oui    | Oui        |   80     | rpm-md | http://download.opensuse.org/repositories/X11:/windowmanagers/openSUSE_11.2/          |        
    6  | http-download.opensuse.org-28652f70 | http-download.opensuse.org-28652f70 | Oui    | Non        |  120     | rpm-md | http://download.opensuse.org/repositories/devel%3a/languages%3a/python/openSUSE_11.2/ |        
    7  | http-download.opensuse.org-f020c876 | http-download.opensuse.org-f020c876 | Oui    | Non        |   99     | rpm-md | http://download.opensuse.org/repositories/devel%3a/languages%3a/perl/openSUSE_11.2/   |        
    8  | nouveau                             | nouveau                             | Oui    | Non        |  200     | rpm-md | http://download.opensuse.org/repositories/home:/jobermayr/openSUSE_11.2               |        
    9  | nvidia                              | nvidia                              | Oui    | Oui        |   50     | rpm-md | http://download.nvidia.com/opensuse/11.2/                                             |        
    10 | openSUSE 11.2-0                     | openSUSE 11.2-0                     | Non    | Non        |    2     | yast2  | cd:///                                                                                |        
    11 | openSUSE:11.2:Update                | openSUSE:11.2:Update                | Oui    | Oui        |    1     | rpm-md | http://download.opensuse.org/update/11.2/                                             |        
    12 | openSUSE:Factory:Contrib            | openSUSE:Factory:Contrib            | Oui    | Oui        |  200     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/standard/        |        
    13 | repo-debug                          | openSUSE-11.2-Debug                 | Non    | Oui        |    2     | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                        |        
    14 | repo-non-oss                        | openSUSE-11.2-Non-Oss               | Oui    | Oui        |    2     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                          |        
    15 | repo-oss                            | openSUSE-11.2-Oss                   | Oui    | Oui        |    2     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                              |        
    16 | repo-source                         | openSUSE-11.2-Source                | Non    | Oui        |    2     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/
    As of you remark, I tried to set the packman repo to the highest priority, but after that zypper did not suggest any new updates.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: gstreamer issue

    1 | Chromium | Chromium | Oui | Non | 200 | rpm-md | Index of /repositories/home:/dbuck/openSUSE_Factory |
    2 | Fwzs | Fwzs | Oui | Non | 99 | rpm-md | Index of /repositories/home:/lnussel:/fwzs/openSUSE_Factory |
    3 | GNOME:Community | GNOME:Community | Oui | Oui | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_Factory |
    4 | Packman | Packman | Oui | Oui | 10 | rpm-md | Index of /pub/packman/suse/11.2 |
    5 | X11:windowmanagers | X11:windowmanagers | Oui | Oui | 99 | rpm-md | Index of /repositories/X11:/windowmanagers/openSUSE_11.2 |
    6 | http-download.opensuse.org-28652f70 | http-download.opensuse.org-28652f70 | Oui | Non | 120 | rpm-md | Index of /repositories/devel:/languages:/python/openSUSE_11.2 |
    7 | http-download.opensuse.org-f020c876 | http-download.opensuse.org-f020c876 | Oui | Non | 99 | rpm-md | Index of /repositories/devel:/languages:/perl/openSUSE_11.2 |
    8 | nouveau | nouveau | Oui | Non | 200 | rpm-md | Index of /repositories/home:/jobermayr/openSUSE_11.2 |
    9 | nvidia | nvidia | Oui | Oui | 99 | rpm-md | http://download.nvidia.com/opensuse/11.2/ |
    10 | openSUSE 11.2-0 | openSUSE 11.2-0 | Non | Non | 2 | yast2 | cd:/// |
    11 | openSUSE:11.2:Update | openSUSE:11.2:Update | Oui | Oui | 99 | rpm-md | Index of /update/11.2 |
    12 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Oui | Oui | 200 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/standard |
    13 | repo-debug | openSUSE-11.2-Debug | Non | Oui | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    14 | repo-non-oss | openSUSE-11.2-Non-Oss | Oui | Oui | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    15 | repo-oss | openSUSE-11.2-Oss | Oui | Oui | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    16 | repo-source | openSUSE-11.2-Source | Non | Oui | 99 | NONE | Index of /source/distribution/11.2/repo/oss




    Take it from me - Gstreamer is not the recommended one to use. Little that I know.
    Change your priorities as above. Who on earth gave you those settings?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •