Results 1 to 10 of 10

Thread: Accessing 11.2 from XP box

  1. #1

    Default Accessing 11.2 from XP box

    I've performed a fresh/clean install of 11.2 using the DVD .iso. I'm now trying to configure remote access to this machine from an XP box. I downloaded NoMachine's NX product and followed the install instructions. I also opened port 22 on my XP box and verified that Secure Shell Server is allowed in the OpenSuse11.2 firewall. However, I'm getting "Connection Refused"

    I executed "./nxserver --status" on the 11.2 box and get the following: "900 ssh: connect to host 127.0.0.1 port 22: Connection refused"

    Is there something else I need to install on the 11.2 box to allow SSH to work?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,838
    Blog Entries
    15

    Default Re: Accessing 11.2 from XP box

    Quote Originally Posted by pwelte
    I've performed a fresh/clean install of 11.2 using the DVD .iso. I'm now
    trying to configure remote access to this machine from an XP box. I
    downloaded NoMachine's NX product and followed the install
    instructions. I also opened port 22 on my XP box and verified that
    Secure Shell Server is allowed in the OpenSuse11.2 firewall. However,
    I'm getting "Connection Refused"

    I executed "./nxserver --status" on the 11.2 box and get the following:
    "900 ssh: connect to host 127.0.0.1 port 22: Connection refused"

    Is there something else I need to install on the 11.2 box to allow SSH
    to work?
    Hi
    On the XP box you don't need port 22 open only the 11.2 system. Have
    you checked the sshd daemon is running?

    Code:
    sudo /sbin/chkconfig sshd
    Above should say on, else
    Code:
    sudo /sbin/chkconfig sshd on
    sudo /usr/sbin/rcsshd restart
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 1 day 14:44, 3 users, load average: 0.02, 0.09, 0.08
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  3. #3

    Default Re: Accessing 11.2 from XP box

    Just to add to Malcolm's post, also make sure your firewall isn't blocking SSH. It's not enough to simply start the daemon, you either need to turn off the SuSE firewall or allow port 22 inbound on the SuSE Box.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,838
    Blog Entries
    15

    Default Re: Accessing 11.2 from XP box

    Quote Originally Posted by jknarr
    Just to add to Malcolm's post, also make sure your firewall isn't
    blocking SSH. It's not enough to simply start the daemon, you either
    need to turn off the SuSE firewall or allow port 22 inbound on the SuSE
    Box.
    Hi
    The OP had already done this

    "and verified that Secure Shell Server is allowed in the OpenSuse11.2
    firewall"

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 1 day 15:30, 3 users, load average: 0.07, 0.04, 0.07
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  5. #5

    Default Re: Accessing 11.2 from XP box

    sshd wasn't installed by default. I managed to find it and started the installation for it. However it returned a "can't save firewall settings" error during the install. I remembered that I first tried to remote control by turning-on Remote Desktop Administration (which placed an exception for VNC in the firewall). I turned-off Remote Desktop Administration and was able to save the sshd setup. I still wasn't able to get an SSH connection for NX.

    I'll check the sshd config using the above commands and possibly try turning off the OpenSUSE firewall. I'm learning as I go with Linux and don't have much of an experience knowledgebase on which to rely. I appreciate your suggestions.

  6. #6

    Default Re: Accessing 11.2 from XP box

    chkconfig showed sshd was off. I tried to turn it on using "/sbin/chkconfig sshd on" and got the following:
    insserv: warning: script 'K01nxserver' missing LSB tags and overrides
    insserv: warning: script 'K01nxsensor' missing LSB tags and overrides
    insserv: warning: script 'nxsensor' missing LSB tags and overrides
    insserv: warning: script 'nxserver' missing LSB tags and overrides
    insserv: There is a loop between service stoppreload and boot.cleanup if started
    insserv: loop involving service boot.cleanup at depth 3
    insserv: loop involving service boot.localfs at depth 2
    insserv: There is a loop at service stoppreload if started
    insserv: There is a loop between service nxserver and boot.crypto if started
    insserv: loop involving service boot.crypto at depth 1
    :
    :
    insserv: Max recursions depth 99 reached
    insserv: loop involving service xdm at depth 2
    :
    :
    insserv: exiting without changing boot order!
    /sbin/insserv failed, exit code 1

    I'm going to remove the NX node/server/client and then try to turn-on sshd.

  7. #7

    Default Re: Accessing 11.2 from XP box -SOLVED

    Thanks Malcolm for pointing me in the right direction. I uninstalled NX, then re-installed sshd and verified it was on. I was then able to successfully install NX. I am now connected from an XP box to the OpenSUSE 11.2 box (with firewall on). Now I can play around with this OpenSUSE machine without leaving my desk!

  8. #8

    Default Re: Accessing 11.2 from XP box - *** FollowUp Question ***

    Is there a way to remotely access a specific OpenSUSE desktop/session? I'm logged in as UserA on the OpenSUSE 11.2 box. When I connect via NX from my XP box, I get a new desktop session. For remote support purposes, I'd like to be able to get access to the UserA desktop. Is this possible?

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,838
    Blog Entries
    15

    Default Re: Accessing 11.2 from XP box

    Quote Originally Posted by pwelte
    Is there a way to remotely access a specific OpenSUSE desktop/session?
    I'm logged in as UserA on the OpenSUSE 11.2 box. When I connect via NX
    from my XP box, I get a new desktop session. For remote support
    purposes, I'd like to be able to get access to the UserA desktop. Is
    this possible?
    Hi
    In Gnome you just need to enable the remote desktop via the Control
    Center, then follow this guide;
    http://www.nomachine.com/howto/vnc-session.php

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 1 day 18:29, 4 users, load average: 0.12, 0.14, 0.10
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  10. #10

    Default Re: Accessing 11.2 from XP box

    I'm using 11.2's default desktop of KDE and getting "The NX service is not available or the NX access was disabled on host...." when I try to connect (I've enabled Remote Desktop).

    Is this because I've already setup NX for remote access using public key or does KDE not support NX-to-VNC connections?

    I'll try to switch to the Gnome desktop to see if it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •