Results 1 to 7 of 7

Thread: very strange behavior after upgrading from 10.3 to 11.2

  1. #1
    Join Date
    Nov 2009
    Posts
    18

    Default very strange behavior after upgrading from 10.3 to 11.2

    Hello,

    I have dared upgrading OpenSUSE 10.3 directly to 11.2. And it almost worked...

    After upgrading the system boots, but some operations last for a very long time.
    For example: on the login screen it takes a lot of time for the login/password
    box to appear. But the display icon (which is on the same screen!) is very fast
    and responsive.

    After logging into the system, I have to wait a few minutes for the desktop
    to appear (I mean the menus, the wallpaper etc.). When I open the Gnome terminal,
    I can work in it without problems, however when (using the same terminal) I
    try to do "su -", after I type in the password, I have to wait for a very long
    time to log as root.

    The CPU usage is OK (i.e. it's very low).

    There following error messages appear in /var/log/messages after I do "su -"
    and enter the password:

    gnomesu-pam-backend: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-oiJdty/socket
    gnomesu-pam-backend: gkr-pam: couldn't unlock 'login' keyring: 255


    Also, when booting the machine, there are these error messages in the /var/log/messages file:

    [...]
    auditd[2112]: Error sending signal_info request (Operation not supported)
    [...]
    seahorse-agent[15536]: GConf error:#012 Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Could not send message to GConf daemon: Connection is closed)
    [...]

    I am not using NFS.

    Generally the Gnome environment is very responsive (e.g. switching between windows
    is very fast). It's just that some operations take very long time to complete.

    May I ask for any help?

    Greetings,
    Tomek.

  2. #2
    Join Date
    Nov 2009
    Posts
    18

    Default Re: very strange behavior after upgrading from 10.3 to 11.2

    Update: I have compared system log with the one from another PC (where I also installed OpenSUSE 11.2),
    and there are the same error messages. However, on this other PC OpenSUSE works perfectly.

    So, there must be something else...

    Tomek.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,793
    Blog Entries
    14

    Default Re: very strange behavior after upgrading from 10.3 to 11.2

    You may ask for help, Tomek, but you've done exactly that, what's been suggested NOT TO DO. Performing a clean install is the way to go. It's almost impossible for us to find out what's going wrong, since your system might very well contain a mix of 10.3 and 11.2 packages.

    What you've done is practically the road to instability.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Nov 2009
    Posts
    18

    Default Re: very strange behavior after upgrading from 10.3 to 11.2

    Quote Originally Posted by Knurpht View Post
    You may ask for help, Tomek, but you've done exactly that, what's been suggested NOT TO DO. Performing a clean install is the way to go. It's almost impossible for us to find out what's going wrong, since your system might very well contain a mix of 10.3 and 11.2 packages.

    What you've done is practically the road to instability.
    Thanks for your reply. Yes, I know it's been risky.

    Would it be OK if I booted from the install DVD, and chosen the "Repair" option? Would it overwrite all packages or should I rather delete everything and start from scratch?

    Greetings,
    Tomek.

  5. #5
    palladium NNTP User

    Default Re: very strange behavior after upgrading from 10.3 to 11.2

    > May I ask for any help?

    my _guess_ is the easiest way to fix all the problems is to back up
    all the data you wanna keep and do fresh format and install 11.2 from
    DVD, then restore from your current backup..

    well, you can try preserving your current /home and let it be the new
    home, but chances are there is some crud in its hidden directories
    that contain traps and dangers not easily repaired..

    note: i'm sending from a rock solid 10.3, which i hate to leave but
    when i do i will remove the old drive, install a new, and give it all
    to openSUSE...including a new user's home....then, i'll attach the old
    again and tranfer data, music etc only....hopefully that way any old
    junk will be left behind..

    ymmv...note, supposedly it is ok to upgrade to 11.2 from 11.1, but.....

    --
    palladium

  6. #6
    Join Date
    Nov 2008
    Location
    Seattle
    Posts
    11

    Default Re: very strange behavior after upgrading from 10.3 to 11.2

    Had nearly the same problems.
    After reading the "Releases" found no information that would be incompatible to update from the 10.3 to 11.0

    Had to go through the school of hard knocks.

    First: The "fstab" file is important and have always had a hard copy in the manual. This was the answer to the incompatibly because the 10.3 was using the journalaling "Reiserfs" where the 11.0 was "ext3" file system. Could never get HOME directory (/dev/sda7) to act anything normal.

    Had to do format and reinstall.
    2 Tips: 1- With dual Boot use the Computer Manager in Windows and delete Linux partitions and enlarge Windows to full then reinstall.
    2- Print out your "fstab" file and have as reference.

    tom
    SuSe 10.3/Dual Boot-XP Laptop

  7. #7
    palladium NNTP User

    Default Re: very strange behavior after upgrading from 10.3 to 11.2

    Thomas7343 wrote:
    > Had nearly the same problems.
    > After reading the "Releases" found no information that would be
    > incompatible to update from the 10.3 to 11.0


    that 10.3 (and all previous _and_ 11.0) to 11.2 upgrade is not
    supported info not make it into the readme? it is carefully hidden
    here: http://en.opensuse.org/Upgrade

    and in many threads in these fora...surprised it didn't make it into
    what you read..

    --
    palladium

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •