Results 1 to 5 of 5

Thread: Vodafone Huawei E220 on openSuSE 11.2

  1. #1
    Join Date
    May 2009
    Location
    Romania, Bucharest
    Posts
    17

    Default Vodafone Huawei E220 on openSuSE 11.2

    Greetings guys.

    I've just installed openSuSE 11.2 and found that my Vodafone Huawei E220 modem is not recognized by 11.2 opensuse distro.

    Previously, on 11.1 I managed to make this modem work fine with my OS, but now after I plug-it and issue an lsusb command even if my OS discovers correctly my modem, there is no /dev/ttyUSB0 displayed when issuing a ls /dev/ttyUSB* command.

    I followed the instructions (as before, on 11.1 version) from this site -- it's in Romanian langauge (sorry, but this is the best configuration tutorial I've found)

    I think I'm doing something wrong (since before it workd fine). Anyway, can anyone help me !?

    P.S. openSuSE 11.2 is even better then 11.1 ... the new KDE work even faster for me and it detected wonderfully all of my Acer Aspire 5920G special features. Keep up the good work guys.

  2. #2

    Default Re: Vodafone Huawei E220 on openSuSE 11.2

    I'm having the same experience, except that when I do ls /dev/ttyUSB* it says that I have both /dev/ttyUSB0 & /dev/ttyUSB1.

    On 11.1 I had in addition to those two also /dev/ttyUSB2 (My E220 cord has two plug-ins to the computer and I assume that that was the reason for having three "/dev/usbs").

  3. #3
    Join Date
    May 2009
    Location
    Romania, Bucharest
    Posts
    17

    Default Re: Vodafone Huawei E220 on openSuSE 11.2

    After some time spent on the Internet, I managed to make my Huawei E220 modem work with 11.2 (sometimes). Here is how :

    1. Plug in the modem.
    2. Open a terminal and issue a lsusb command.
    3. You should see something like this:
    ..........
    Bus 003 Device 008: ID 12d1:1003 Huawei ...
    ..........

    3. If you see this, then type sudo modprobe usbserial vendor=0x12d1 product=0x1003 and then Enter.
    4. Now KNetworkManager should see that the modem is connected and you'll be able to configure it.

    P.S. For Romanian Vodafone RO clients of Mobile Internet follow these instructions     IT City: Configurare Modem Vodafone E220 Pe Linux

    However, as I stated first, it only works sometimes. Sometimes when you attempt to connect it will just remain at the "Activating" stage. Don't know why ?! Can anyone help me now !?

  4. #4
    kr_chooses_life NNTP User

    Default Re: Vodafone Huawei E220 on openSuSE 11.2

    failed to get my Huawei E220 (O2 Ireland) recognised after installing Opensuse 11.2 Gnome. worked in 11.1 with same hardware without problems. an observation: if I install Opensuse 11.2 with KDE desktop, the modem is recognised, and works with Network Manager out of the box. I miss my Gnome though

  5. #5

    Default Re: Vodafone Huawei E220 on openSuSE 11.2

    Hi, I need your help...
    when I installed openSUSE 11.2 last month my E220 Huawei 3G Modem worked fine. Now, I don't have internet. But if logged in as root works fine, the problem are the other users when they logon the modem does not work. how can I fix this fault?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •