Results 1 to 5 of 5

Thread: I want amaroK

  1. #1
    Join Date
    Jun 2008
    Location
    Srbija
    Posts
    217

    Default I want amaroK

    Hi all,
    I was wondering how to install latest amarok.
    The one installed now is default for 11.2, its working well with xine1 but I would like the new one.
    Found it in the repos but there are over a 150 dependences, can someone explain it to me without having to install (and destabilize) new kde or 150 rpms?

    Thx
    VERBA VOLANT, SCRIPTA MANENT

  2. #2
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: I want amaroK

    Quote Originally Posted by SLK021 View Post
    Hi all,
    I was wondering how to install latest amarok.
    The one installed now is default for 11.2, its working well with xine1 but I would like the new one.
    Found it in the repos but there are over a 150 dependences, can someone explain it to me without having to install (and destabilize) new kde or 150 rpms?

    Thx

    First off, what repos do you have?

    Code:
    zypper lr -d
    then run
    Code:
    zypper in --debug-solver amarok-[version]
    Where I put in [version], you put in the actual version, for example, 2.2.1 So it may look something like this.
    Code:
    zypper ve --debug-solver amarok-2.2.1
    It will create a large, rather long files in this directory /var/log/zypper.solverTestCase

    Read more here: Zypper/Troubleshooting - openSUSE
    And here: Zypper/Usage/11.2 - openSUSE
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

  3. #3
    Join Date
    Jun 2008
    Location
    Srbija
    Posts
    217

    Default Re: I want amaroK

    zypper lr -d
    Code:
    #  | Alias                               | Name                                        | Enabled | Refresh | Priority | Type   | URI                                                                            | Service
    ---+-------------------------------------+---------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------+--------
    1  | Packman Repository                  | Packman Repository                          | Yes     | Yes     |   50     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.2/                                    | 
    2  | Playground                          | Playground                                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Playground/openSUSE_11.2/ | 
    3  | download.opensuse.org-Community     | openSUSE BuildService - KDE:KDE4:Community  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2/  | 
    4  | download.opensuse.org-webcam        | openSUSE BuildService - Drivers for webcams | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/drivers:/webcam/openSUSE_11.2/       | 
    5  | http-download.opensuse.org-8f000fe4 | Updates for openSUSE 11.2-0                 | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.2/                                      | 
    6  | nVIDIA                              | nVIDIA                                      | Yes     | No      |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.2/                                       | 
    7  | repo-debug                          | openSUSE-11.2-Debug                         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                 | 
    8  | repo-non-oss                        | openSUSE-11.2-Non-Oss                       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                   | 
    9  | repo-oss                            | openSUSE-11.2-Oss                           | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                       | 
    10 | repo-source                         | openSUSE-11.2-Source                        | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/                |
    I read that latest builds are in KDE Playground
    Download:SUSE - Amarok Wiki

    Code:
    ypper in amarok-2.1.1
    Loading repository data...
    Reading installed packages...
    'amarok' providing 'amarok=2.1.1' is already installed.
    Thats to be expected but when I try a different version its not there
    Code:
    zypper in amarok-2.2.1
    Loading repository data...
    Reading installed packages...
    'amarok-2.2.1' not found.
    Same for 2.2.0

    Is there a repo with new amarok, can I just find a rpm and install without dependences?
    Its now getting a little confusing, sorry.

    Thx for the reply
    VERBA VOLANT, SCRIPTA MANENT

  4. #4

    Default Re: I want amaroK

    Try the KDE43 Repo
    I don't know how much dependencies you have to download but it has the latest 2.2.1-43
    My Blog: http://pdg86.wordpress.com
    Arch Linux / openSUSE 11.2 / Slackware-Current

  5. #5
    Join Date
    Jun 2008
    Location
    Srbija
    Posts
    217

    Default Re: I want amaroK

    Code:
    The following packages are going to be upgraded:
      amarok kde4-filesystem kdebase4-runtime kdelibs4 kdelibs4-core libkde4 libkdecore4 oxygen-icon-theme oxygen-icon-theme-scalable python-kde4 python-kdebase4 taglib
    And it was done.

    Appreciate it, new amarok relay rocks
    VERBA VOLANT, SCRIPTA MANENT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •