Results 1 to 10 of 10

Thread: How to change KDM font size on OpenSUSE 11.2?

Hybrid View

  1. #1

    Cool How to change KDM font size on OpenSUSE 11.2?

    Hi All

    I'm running OpenSUSE 11.2 on my Acer Aspire One with a 9 inch LCD. I have configured the monitor in Sax2 to reflect the size and 1024x600 resolution, and as a result the desktop fonts are all sized correctly.

    However, the fonts on the KDM log-in screen are too large, and I'd like to reduce them if possible. Looking in the KDE Control Center, I tried using the Login Manager utility to adjust the KDM theme, but any changes I made seemed to have no effect i.e. changing the font size, or even the overall theme itself, still resulted in KDM using the default green OpenSUSE theme with large fonts.

    Does anyone know, therefore, how to adjust the KDM font size or DPI in OpenSUSE 11.2?

    Thanks
    Nick

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,452

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    Configure Desktop>Appearance>Fonts

  3. #3

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    Thanks John, but unless I'm missing something, your suggestion will only allow me to change the KDE desktop fonts, not those for KDM.

    Nick.

  4. #4
    iestyn574 NNTP User

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    The font size in KDM will follow whatever defaults you set in your xorg.conf file - I had this issue in OpenSuse 11.2 with an Nvidia 9800GT card when using a 42 Inch Samsung TV for my display. Forcing xorg to use 96 DPI was the trick for me. Some good info here: Xorg - ArchWiki - Look for DPI.

    Regards,

    Iestyn

  5. #5

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    Thanks iestyn for the advice - that sounded very promising, and the archlinux link is very useful.

    Problem is, making changes to /etc/X11/xorg.conf still seems to have no impact on KDM. Here's what I've changed:

    1. I changed the display size in the 'Monitor' section to reflect the precise measurements of my Aspire One's screen (this had the positive affect of making Sax2 correctly report my monitor as 8.9 inches and not 10 inches):

    DisplaySize 195 115

    2. I added the following line to the 'Device' section as per the archlinux site, to force disable automatic DPI detection:

    Option "NoDDC" "true"

    So neither of these changes have had any effect on KDM which is quite confusing as I'd have thought global changes to xorg.conf would affect all graphical applications.

    Nick

  6. #6
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    243

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    Quote Originally Posted by nickogecko View Post
    However, the fonts on the KDM log-in screen are too large, and I'd like to reduce them if possible. Looking in the KDE Control Center, I tried using the Login Manager utility to adjust the KDM theme, but any changes I made seemed to have no effect i.e. changing the font size, or even the overall theme itself, still resulted in KDM using the default green OpenSUSE theme with large fonts.
    Maybe this is due to an old bug in KDM theme ?
    See this thread: kdm4 version ? display manager editor ?

    Try to edited /etc/sysconfig and remove anything that is under Desktop->Display Manager->DISPLAYMANAGER_KDM_THEME
    Then change the font with the Login Manager and see if it helps.
    The dark side of the American Dream of few may enjoy is that it is often built upon the nightmare many have to live with.

  7. #7
    iestyn574 NNTP User

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    Hmm, I wonder if you could try 120 DPI instead of 96? Could you go back to the Displaysize parameter in the Monitor section of the xorg.conf, and recalculate the size based on 120 DPI? Just thinking out loud...

    Failing that, perhaps chase down the Xstartup file for KDM and see what could be done in there - As in, perhaps use xrandr and specify the DPI in the X startup file. Not sure where else to go with this one. I suppose as a hack you could use GDM; if your conscience will bear defeat

    Regards,

    Iestyn

  8. #8

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    AmigaPhil - firstly, as an ex-A500 and A1200 owner, I appreciate your help! Your suggestion was correct in that by removing the 'SUSE' option in the /etc/sysconfig editor, I then gained some control over the Login Manager. The changes it allowed me to make, though, were still hit-and-miss, so I've put that to one side for now.

    Iestyn, thanks again for your additional help. Both your post, and AmigaPhil's, got me looking in more detail at /etc/sysconfig editor, and I believe, in theory, adding '-dpi 96' to DISPLAYMANAGER_KDM_LOCALARGS should work, but to no avail. To be honest, despite your stirring words of encouragement, I'm ready to leave this, well, for tonight at least. It's just a cosmetic issue, but it would be nice to fix it at some point.

    Cheers
    Nick.

  9. #9
    puretri NNTP User

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    Hi Nick.

    I had a similar problem. Adding -dpi 120 between the quotation marks at the end of DISPLAYMANAGER_KDM_LOCALARGS after 2-3 reboots gave my kdm screen the right look. Just to clarify it looked like this DISPLAYMANAGER_KDM_LOCALARGS="-dpi 120" in etc/sysconfig. I assume you could change the dpi to whatever you wanted. By the way im using suse 11.2. Hope this helps and isnt more confusing.

  10. #10
    Join Date
    Jan 2008
    Location
    Darmstadt, Germany
    Posts
    478

    Default Re: How to change KDM font size on OpenSUSE 11.2?

    I had a similar problem. Adding -dpi 120 between the quotation marks at the end of DISPLAYMANAGER_KDM_LOCALARGS after 2-3 reboots gave my kdm screen the right look. Just to clarify it looked like this DISPLAYMANAGER_KDM_LOCALARGS="-dpi 120" in etc/sysconfig. I assume you could change the dpi to whatever you wanted. By the way im using suse 11.2. Hope this helps and isnt more confusing.
    It isn't confusing but a rather good hint. Actually it pretty much does the same as I asked for at DPI in openSUSE 11.2 (KDE) - openSUSE Forums yesterday.
    Just funny that it needed "2-3 reboots" for ya. I'd assume a configuration is either applied or it is not

    Thanks for sharing this, will try it asap!

    Best,
    R

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •