Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Firefox doesn't open from clicking on link Thunderbird

  1. #1
    Join Date
    Jun 2008
    Location
    Sunset Valley, Tejas, USA
    Posts
    278

    Default Firefox doesn't open from clicking on link Thunderbird

    OS 11.2 Thunderbird 2.0.0.23 and FF 3.5.4 Clicking on a link in an email doesn't call FF. How do I make the connection?

    I had OS 11.2 RC2 it worked fine after upgrading to GM it broke the connection.

    Thanks,
    Ron

  2. #2
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    Hi Ron,

    IMHO The "Default Application" system settings has a bug or is broken.

    I have a workaround so that you can launch Firefox from within Thunderbird.


    Please read refer to my earlier post below: Cannot launch URL from Thunderbird 3.04b to Firefox"


    Good Luck!
    My Linux Box
    OS:
    openSUSE 42.3 - Plasma 5.8.7
    OS:
    Tumbleweed Plasma 5.15.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  3. #3
    Join Date
    Jun 2008
    Location
    Sunset Valley, Tejas, USA
    Posts
    278

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    Quote Originally Posted by Romanator View Post
    Hi Ron,

    IMHO The "Default Application" system settings has a bug or is broken.

    I have a workaround so that you can launch Firefox from within Thunderbird.


    Please read refer to my earlier post below: Cannot launch URL from Thunderbird 3.04b to Firefox"


    Good Luck!

    That didn't work,
    Ron

  4. #4

    Default Re: Firefox doesn't open from clicking on link Thunderbird


  5. #5

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    Well this is documented in a bug report:
    https://bugzilla.novell.com/show_bug.cgi?id=551333

    A workaround seems to me is to add into ~/.kde4/Autostart/firefox

    the two lines:
    Code:
    gconftool-2 -s --type=string /desktop/gnome/url-handlers/http/command "/usr/bin/firefox \"%s\""
    gconftool-2 -s --type=string /desktop/gnome/url-handlers/https/command "/usr/bin/firefox \"%s\""
    Don't forget to make the file executable. I do not have another solution at the moment, but it works for me.

    Regards,
    Dennis

  6. #6
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    Ah ha!! From what I read in Novell Bugzilla, this originally started as a possible GNOME packaging problem.

    I know for a fact this worked ( Thunderbird and Firefox ) in 11.2 Milestone 1 through Milestone 8. It was broken by the time 11.2 RC1, RC2 and openSUSE 11.2 were available.

    Any thoughts?
    My Linux Box
    OS:
    openSUSE 42.3 - Plasma 5.8.7
    OS:
    Tumbleweed Plasma 5.15.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  7. #7
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    This a follow up to the bug found about Thunderbird not being able to start up Firefox.


    • Add the Stable 4.3.1 Core link to Yast
    • Click on Switch system packages to the versions in the repository openSUSE 11.2 Stable Core 4.3.1
    • After updating - Log out and reboot your system



    Add this link to Yast below:

    Good Luck!
    My Linux Box
    OS:
    openSUSE 42.3 - Plasma 5.8.7
    OS:
    Tumbleweed Plasma 5.15.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    After updating the 4.3.1 Stable Core library in openSUSE 11.2, Thunderbird now launches Firefox in KDE-4.3.1.


    Let me know how it turns out.



    Good Luck!
    My Linux Box
    OS:
    openSUSE 42.3 - Plasma 5.8.7
    OS:
    Tumbleweed Plasma 5.15.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  9. #9
    Join Date
    Jun 2008
    Location
    Sunset Valley, Tejas, USA
    Posts
    278

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    Quote Originally Posted by Romanator View Post
    This a follow up to the bug found about Thunderbird not being able to start up Firefox.


    • Click on Switch system packages to the versions in the repository openSUSE 11.2 Stable Core 4.3.1
    I don't understand. How do you do this?


    [/QUOTE]Add this link to Yast below:[/QUOTE]

    Done.

    Good Luck![/QUOTE]

    Thanks, we will get there eventually.
    Ron

  10. #10
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: Firefox doesn't open from clicking on link Thunderbird

    1. Navigate to the taskbar - far left corner and click on the green gecko
    2. Select Computer --> Yast - Type in your password
    3. Navigate to Software --> Add-On Products. This will start the Package Manager.
    4. Click on the Add button -->Specify URL --> Click on the Next buttton
    5. Copy and paste the link I provided in the "URL field" and create a name in the Repository Name field i.e. Stable 4.3.1



    The rest is straight forward about updating the software.
    My Linux Box
    OS:
    openSUSE 42.3 - Plasma 5.8.7
    OS:
    Tumbleweed Plasma 5.15.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •