Results 1 to 2 of 2

Thread: Evolution in 11.2 backup - restore problem

  1. #1

    Default Evolution in 11.2 backup - restore problem

    I added Evolution to the default KDE desktop in SUSE 11.2 (two days after the 11.2 release). I placed the Evolution backup file evolution-backup.tar.gz written by an older SUSE 11.1 install into a Home subdirectory named upgrade 11_2. The new 11.2 install (full install on a freshly formatted drive) Evolution backup restore kept telling me it was not a valid backup file and failed. At first I figured SUSE 11.2 wouldn't be usable and even the new SUSE 11.2 Evolution wouldn't restore its own backup from the upgrade 11_2 directory where it wrote it to (exact same error message). Then I tried moving the 11.1 Evolution backup file from the upgrade 11_2 directory up one to my Home directory and Evolution backup restore worked. Evolution was actually rejecting either the file location and/or directory name, not the file contents as invalid. Strange since Evolution backup was navigated into this subdirectory to write the backup file without any complaint.

    Has anyone else run into this, or was I just specially cursed for trying to organize my upgrade files?

    This problem almost caused me to judge 11.2 as an upgrade failure, cut my losses time wise and abandon 11.2.

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Evolution in 11.2 backup - restore problem

    Quote Originally Posted by Mike_unique View Post
    I added Evolution to the default KDE desktop in SUSE 11.2 (two days after the 11.2 release). I placed the Evolution backup file evolution-backup.tar.gz written by an older SUSE 11.1 install into a Home subdirectory named upgrade 11_2. The new 11.2 install (full install on a freshly formatted drive) Evolution backup restore kept telling me it was not a valid backup file and failed. At first I figured SUSE 11.2 wouldn't be usable and even the new SUSE 11.2 Evolution wouldn't restore its own backup from the upgrade 11_2 directory where it wrote it to (exact same error message). Then I tried moving the 11.1 Evolution backup file from the upgrade 11_2 directory up one to my Home directory and Evolution backup restore worked. Evolution was actually rejecting either the file location and/or directory name, not the file contents as invalid. Strange since Evolution backup was navigated into this subdirectory to write the backup file without any complaint.

    Has anyone else run into this, or was I just specially cursed for trying to organize my upgrade files?
    You made me curious, so I tested it on my machine. Evolution doesn't seem to handle spaces in the path to the backup file. You might report this as a bug.

    This problem almost caused me to judge 11.2 as an upgrade failure, cut my losses time wise and abandon 11.2.
    There are less drastic approaches, including what you did. You might test the backup with tar (list the contents, extract a few files). You might also do a test backup and restore in Evolution to be sure that is working properly. Finally, you might check things like permissions in the directory to see if there is anything unusual there.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •