Results 1 to 8 of 8

Thread: CiscoVPN and sound issues have upgrade to 11.2

  1. #1

    Default CiscoVPN and sound issues have upgrade to 11.2

    I upgraded my thinkpad t61p from 11 to 11.2 and have two major problems.

    1) CiscoVPN won't compile, I get a linuxcniapi.c:455: error: struct sk_buff errors.

    2) I have no audio, no video play back. reinstalled mplayer and mplayer plugin.

    Help

  2. #2

    Default Re: CiscoVPN and sound issues have upgrade to 11.2

    sø., 15.11.2009 kl. 12.46 +0000, skrev ahidalgo:
    > I upgraded my thinkpad t61p from 11 to 11.2 and have two major problems.
    >
    >
    > 1) CiscoVPN won't compile, I get a linuxcniapi.c:455: error: ‘struct
    > sk_buff’ errors.
    >
    > 2) I have no audio, no video play back. reinstalled mplayer and mplayer
    > plugin.
    >



    gnome or kde?

    And have you tried the vpnc ( and with networkmanager friends)


    bjolie@embla:~> zypper se -i vpnc
    Laster arkivdata...
    Leser installerte pakker...

    S | Navn | Sammendrag |
    Type
    --+---------------------------+-------------------------------------+------
    i | NetworkManager-vpnc | NetworkManager VPN Support for vpnc |
    i | NetworkManager-vpnc-gnome | NetworkManager VPN Support for vpnc |
    i | vpnc | A Client for Cisco VPN concentrator |
    bjolie@embla:~>


    Works like a charm for my jobs cisco vpn

    Not replying on the audio thing since this is very dependant on
    kde/gnome


  3. #3

    Default Re: CiscoVPN and sound issues have upgrade to 11.2

    I'm using kde.

    I tried kvpnc and it connects but won't let me connect.

  4. #4

    Default Re: CiscoVPN and sound issues have upgrade to 11.2

    sø., 15.11.2009 kl. 13.26 +0000, skrev ahidalgo:
    > I'm using kde.
    >
    > I tried kvpnc and it connects but won't let me connect.
    >
    >

    then fire up vpnc in a terminal and tell us what it says.


  5. #5

    Default Re: CiscoVPN and sound issues have upgrade to 11.2

    Quote Originally Posted by ahidalgo View Post
    I upgraded my thinkpad t61p from 11 to 11.2 and have two major problems.

    1) CiscoVPN won't compile, I get a linuxcniapi.c:455: error: struct sk_buff errors.
    Help
    If you're using the proprietary vpnclient on x64, here's what I did to get it working:

    1. downloaded the app from [projects.tuxx-home.at] (check the links on teh left side for downloads)
    2. grab the 4.8.02-64bit patch from teh same site
    3. grab the patch from this site: Ilap's tech: Cisco VPN Client on Karmic Koala (it's for ubuntu, I know, but they use 2.6.31 too)

    4. unpack the .tar.gz from step 1
    5. cd vpnclient/
    6. patch < ../vpnclient-linux-4.8.02-64bit.patch
    7. patch < ../cisco-vpnclient.2.6.31.diff
    8. sudo ./vpn_install

    (I did all of this after installing teh ATi drivers, so I had kernel-headers and kernel-source already)

  6. #6

    Post Re: CiscoVPN and sound issues have upgrade to 11.2

    Hi there,

    I had the issue with Cisco vpnclient not working on the new Suse 2.6.31 kernel and used a similar patch procedure as that given above, but I used: How to install Cisco VPN client on Ubuntu Jaunty Jackalope and Karmic Koala 64 bit | L.A.M.N.K, adding the patch for newer kernels and it there after compiled fine. Please see that thread though as you may also have to change a line in the kernel source too, not just patch the vpn client. I summarized the steps I used on my wiki at Cisco VPN Configuration - Lyceum

    The sed command to modify the kernel soure I used (which I got from LAMNK) and other steps were:

    Code:
    cd vpnclient
    wget http://lamnk.com/download/vpnclient-....31-final.diff
    vim vpnclient-linux-2.6.31-final.diff
    patch < ./vpnclient-linux-2.6.31-final.diff
    sudo sed -i 's/const\ struct\ net_device_ops\ \*netdev_ops;/struct\ net_device_ops\ \*netdev_ops;/' `find /usr/src -name netdevice.h`
    ./vpn_install
    /etc/init.d/vpnclient_init start
    You should just add the 64 bit patch too, and you should then be able to rebuild the module - - make sure you run ./vpn_install for it to correctly rebuild it for you.

    Cheers,
    Lews Therin

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: CiscoVPN and sound issues have upgrade to 11.2

    Quote Originally Posted by ahidalgo View Post
    2) I have no audio, no video play back. reinstalled mplayer and mplayer plugin.
    I recommend you sort your sound problem in a different thread. Please advise output of the 3 sound tests (2 speaker and one from alsa web site): SDB:AudioTroubleshooting - openSUSE

  8. #8

    Default Re: CiscoVPN and sound issues have upgrade to 11.2

    Thanks!, that worked to fix vpn.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •