Results 1 to 2 of 2

Thread: Wine / Crossover Games problem after upgrade to 11.2

  1. #1

    Unhappy Wine / Crossover Games problem after upgrade to 11.2

    Hi all,

    I seem to have experienced a regression issue in my recent zypper dup from 11.1 to 11.2.

    I have an older game (Arcanum) which was running great under Wine / Crossover Games in Suse 11.1. Now however, when I try to start it, either using the Crossover Games version of Wine, or the Suse RPM version of wine, I get the same result. The screen changes mode and then . . . nothing. With verbose output I get the following error:

    Running `"/home/paracelsus/cxgames/bin/cxavscan" "/home/paracelsus/.cxgames/Arcanum/drive_c/Program Files/MidgetReaper/Arcanum Ultima/Arcanum/Arcanum.exe"`
    -> rc=768  (took 0.0625109672546387 seconds)
    /home/paracelsus/cxgames/bin/wineloader winewrapper.exe --run -- /home/paracelsus/.cxgames/Arcanum/drive_c/Program Files/MidgetReaper/Arcanum Ultima/Arcanum/Arcanum.exe -no3d -doublebuffer -window
    ** Sat Nov 14 19:08:23 2009
    Starting '/home/paracelsus/cxgames/bin/wineloader' 'winewrapper.exe' '--run' '--'
    '/home/paracelsus/.cxgames/Arcanum/drive_c/Program Files/MidgetReaper/Arcanum Ultima/Arcanum/Arcanum.exe' '-no3d' '-doublebuffer' '-window'
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f690,0x00000000), stub!
    From what I can tell this is more an X server or kernel issue, or possibly the Nvidia drivers, I say that because: while Wine was updated in the dist upgrade, the Crossover games version was not and thus is unchanged from when the games worked. Of course the kernel, Xserver and Nvidia driver were all updated to new versions though.

    I've Googled from more info on fixme:win:EnumDisplayDevicesW but have not found much useful info.

    Callandor:~ # glxinfo | grep direct
    direct rendering: Yes
    Callandor:~ # rpm -qa | grep nvidia
    Callandor:~ # uname -a
    Linux Callandor #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux
    paracelsus@Callandor:/> wine --version
    paracelsus@Callandor:/> ~/cxgames/bin/wine --version
    Product Name: CrossOver Games
    Public Version: 8.0.0
    Product Version: 8.0.0
    Build Tag: cxgames-8.0.0rc6
    Build Timestamp: 20090901T211151Z
    My xrandr setup (not too exciting):
    Callandor:~ # xrandr
    Screen 0: minimum 320 x 240, current 1680 x 1050, maximum 1680 x 1050
    default connected 1680x1050+0+0 (normal left inverted right) 0mm x 0mm
       1680x1050      50.0*
       1600x1000      51.0
       1400x1050      52.0     60.0
       1280x1024      53.0     61.0
       1440x900       54.0
       1280x960       55.0
       1152x864       56.0
       1024x768       57.0     63.0     64.0
       800x600        58.0     67.0     68.0     69.0     70.0     71.0
       640x480        59.0     74.0     75.0     76.0
       1152x720       62.0
       896x672        65.0
       832x624        66.0
       640x512        72.0     73.0
       576x432        77.0
       512x384        78.0     79.0     80.0
       416x312        81.0
       400x300        82.0     83.0     84.0     85.0
       320x240        86.0     87.0     88.0
    I tried turning off compositing and using my old (pre Suse 11.2) xorg.conf but no luck.

    Does anyone have any bright ideas on what I might be able to do to get this working? I JUST had this working and really want to play this game again, it's been years since I played it, and it's a bit disappointing to not be able to play it now. <sniff>

    Thank you,
    Lews Therin

  2. #2

    Post Re: Wine / Crossover Games problem after upgrade to 11.2

    Well, I tried to zero in on this a bit more. I replaced the default 11.2 kernel with the desktop kernel:
    paracelsus@Callandor:~> uname -a
    Linux Callandor #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux
    This did not resolve the issue and wine / crossover still crashes out with the same error:
    ** Sun Nov 15 16:36:28 2009
    Starting '/home/paracelsus/cxgames/bin/wineloader' 'winewrapper.exe' '--run' '--'
    '/home/paracelsus/.cxgames/Arcanum/drive_c/Program Files/MidgetReaper/Arcanum Ultima/Arcanum/Arcanum.exe' '-no3d' '-doublebuffer'
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f690,0x00000000), stub!
    fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 16
    So I then decided to try compiling the latest Nvidia drivers from source as perhaps the 11.2 packaged ones had a glitch. However, after compiling using the release, I still get exactly the same issue.

    Hummm . . .with so little to go on, I am at a bit of a loss. Does anyone have any ideas on a direction to take that might be successful?

    Lews Therin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts