Results 1 to 9 of 9

Thread: k3b missing pluggin

  1. #1

    Default k3b missing pluggin

    Running k3b right from default 11.2 install. I get this message when running it. I assume its just like it states "for legal reasons" but I aleady have libmad installed?

    Mp3 Audio Decoder plugin not found.
    K3b could not load or find the Mp3 decoder plugin. This means that you will not be able to create Audio CDs from Mp3 files. Many Linux distributions do not include Mp3 support for legal reasons.
    Solution: To enable Mp3 support, please install the MAD Mp3 decoding library as well as the K3b MAD Mp3 decoder plugin (the latter may already be installed but not functional due to the missing libmad). Some distributions allow installation of Mp3 support via an online update tool (e.g. SuSE's YOU).

  2. #2
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    518

    Default Re: k3b missing pluggin

    Hey jaybott.

    Have a look at this. Restricted Formats - openSUSE

  3. #3

    Default Re: k3b missing pluggin

    Looks like the older version of kde4 k3b had its own codecs package but the new one that comes with opensuse 11.2 doesn't have this???

  4. #4
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    518

    Default Re: k3b missing pluggin

    I have not done it yet, but it looks like you could install the Packman Repository and grab kde4-k3b-devel from there. I think it has the required support for MP3.

    Someone else may know for sure. Please correct if I am wrong on this.

  5. #5
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    518

    Default Re: k3b missing pluggin

    I did a little more digging and it looks like you need to grab the following from Pacman's Repo

    kde4-k3b-codecs

    You can also get some more codecs for assorted other formats.

    w32codec-all
    libavcodec52
    libtheora0
    libxine1-codecs
    jflac
    dirac
    xvidcore

  6. #6

    Default Re: k3b missing pluggin

    So this is what I have found so far.

    If you try and install the codecs for k3b kde4 it forces you to install k3b 1.66. Opensuse 11.2 comes with k3b 1.68. So the question is why is there no codecs for 1.68 in the repos? I guess for now I could just downgrade to the older version.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: k3b missing pluggin

    I removed the suse k3b
    Installed kde4-k3b and codecs package from Packman
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: k3b missing pluggin

    Same here, that version works just fine.

  9. #9

    Thumbs up Re: k3b missing pluggin

    Quote Originally Posted by Wilson_Phillips View Post
    I have not done it yet, but it looks like you could install the Packman Repository and grab kde4-k3b-devel from there. I think it has the required support for MP3.

    Someone else may know for sure. Please correct if I am wrong on this.
    Hey thank you very much! Installing k3b-devel did the magical trick for me (also with the newest version of k3b from packman repository - currently 1.69).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •